Find Small A

As is known to all,the ASCII of character ‘a’ is 97. Now,find out how many character ‘a’ in a group of given numbers. Please note that the numbers here are given by 32 bits’ integers in the computer.That means,1digit represents 4 characters(one character is represented by 8 bits’ binary digits).
Input
The input contains a set of test data.The first number is one positive integer N (1≤N≤100),and then N positive integersai (1≤ aiai≤2^32 - 1) follow
Output
Output one line,including an integer representing the number of ‘a’ in the group of given numbers.
Sample Input
3
97 24929 100
Sample Output
3

思路:由于8位二进制28是256,所以对于每个输入的数x:
如果x%256==97,则说明有一个97,答案增加
然后x/256,重复上面步骤直到x为0。

#include"cstdio"
#include"cstring"
#include"iostream"
#include"algorithm"
using namespace std;
int main()
{
	int n;
	scanf("%d",&n);
	int sum=0;
	while(n--)
	{
		int x;
		scanf("%d",&x);
		for(int i=x;i>0;)
		{
			if(i%256==97)
			{
				sum++;
			}
			i/=256;
		}
	}
	printf("%d\n",sum);
	return 0;
 } 
	

另一种是采取位运算取模的方法(这种方法没理解,卑微,5555)。

#include <iostream>
#include <cstdio>
using namespace std;
int main(){
    int n,ans = 0;
    scanf("%d",&n);
    for(int i = 0; i < n; i++){
        int x;
        scanf("%d",&x);
        while(x){
            if(x % (1<<8) == 97) ans++;
            x >>= 8;
        }
    }
    printf("%d\n",ans);
    return 0;
}
发布了76 篇原创文章 · 获赞 1 · 访问量 2767

猜你喜欢

转载自blog.csdn.net/weixin_44824383/article/details/104277892