Find a way HDU - 2612

Pass a year learning in Hangzhou, yifenfei arrival hometown Ningbo at finally. Leave Ningbo one year, yifenfei have many people to meet. Especially a good friend Merceki. 
Yifenfei’s home is at the countryside, but Merceki’s home is in the center of city. So yifenfei made arrangements with Merceki to meet at a KFC. There are many KFC in Ningbo, they want to choose one that let the total time to it be most smallest. 
Now give you a Ningbo map, Both yifenfei and Merceki can move up, down ,left, right to the adjacent road by cost 11 minutes. 

Input

The input contains multiple test cases. 
Each test case include, first two integers n, m. (2<=n,m<=200). 
Next n lines, each line included m character. 
‘Y’ express yifenfei initial position. 
‘M’    express Merceki initial position. 
‘#’ forbid road; 
‘.’ Road. 
‘@’ KCF 

Output

For each test case output the minimum total time that both yifenfei and Merceki to arrival one of KFC.You may sure there is always have a KFC that can let them meet.

Sample Input

4 4
Y.#@
....
.#..
@..M
4 4
Y.#@
....
.#..
@#.M
5 5
Y..@.
.#...
.#...
@..M.
#...#

Sample Output

66
88
66

AC代码:(分别计算两个人到各个kfc的时间然后找相加和最小)

Select Code

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <queue>
#include <cmath>
//#include <bits/stdc++.h>
#define inf 0x3f3f3f3f
#define maxn 210
using namespace std;
int step1[maxn][maxn];
int step2[maxn][maxn];
int vis[maxn][maxn];
char mp[maxn][maxn];
struct node
{
    int x, y;
} st1, st2, s, t;
int n, m;
int nxt[5][3] = {{0,1}, {0,-1}, {1,0}, {-1,0}};
void bfs(struct node st, int step[][210])
{
    queue<node>q;
    q.push(st);
    vis[st.x][st.y] = 1;
    while(!q.empty())
    {
        s = q.front();
        q.pop();
        for(int i = 0;i<4;i++)
        {
            t.x = s.x+nxt[i][0];
            t.y = s.y+nxt[i][1];
            if(t.x>=0&&t.x<n&&t.y>=0&&t.y<m&&!vis[t.x][t.y]&&mp[t.x][t.y]!='#')
            {
                q.push(t);
                vis[t.x][t.y] = 1;
                step[t.x][t.y] = step[s.x][s.y]+1;
            }
        }
    }
    return;
}
int main()
{
    while(scanf("%d %d",&n,&m)!=EOF)
    {
        for(int i = 0;i<n;i++)
        {
            scanf("%s",mp[i]);
            for(int j = 0;j<m;j++)
            {
                if(mp[i][j]=='Y')
                {
                    st1.x = i, st1.y = j;
                }
                else if(mp[i][j]=='M')
                {
                    st2.x = i, st2.y = j;
                }
            }
        }
        memset(step1, 0, sizeof(step1));
        memset(vis, 0, sizeof(vis));
        bfs(st1, step1);
        memset(step2, 0, sizeof(step2));
        memset(vis, 0, sizeof(vis));
        bfs(st2, step2);
        int ans = maxn;
        for(int i = 0;i<n;i++)
        {
            for(int j = 0;j<m;j++)
            {
                int t1 = step1[i][j];
                int t2 = step2[i][j];
                if(t1!=0&&t2!=0&&mp[i][j]=='@')
                {
                    if(ans>(t1+t2))
                    {
                        ans = t1+t2;
                    }
                }
            }
        }
        printf("%d\n",ans*11);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41524782/article/details/81950759