Farey Sequence (欧拉函数)

题目:

The Farey Sequence Fn for any integer n with n >= 2 is the set of irreducible rational numbers a/b with 0 < a < b <= n and gcd(a,b) = 1 arranged in increasing order. The first few are 
F2 = {1/2} 
F3 = {1/3, 1/2, 2/3} 
F4 = {1/4, 1/3, 1/2, 2/3, 3/4} 
F5 = {1/5, 1/4, 1/3, 2/5, 1/2, 3/5, 2/3, 3/4, 4/5} 

You task is to calculate the number of terms in the Farey sequence Fn.

Input

There are several test cases. Each test case has only one line, which contains a positive integer n (2 <= n <= 10 6). There are no blank lines between cases. A line with a single 0 terminates the input.

Output

For each test case, you should output one line, which contains N(n) ---- the number of terms in the Farey sequence Fn. 

Sample Input

2
3
4
5
0

Sample Output

1
3
5
9

题意:

求出题中所给的函数值,F[4]对应1 2 3 4的互质数和(小于本身)

分析:

用欧拉函数筛法,之后再打表即可:

代码:

#include<stdio.h>
#include<iostream>
using namespace std;
const int maxn=1e6+5;
typedef long long ll;
ll prim[maxn];
int n;
void solve()
{
    prim[1]=1;
    for(int i=2;i<=maxn;i++)
    {
        if(!prim[i])
        {
            prim[i]=i-1;//欧拉函数定理:质数的欧拉函数为质数减一;
            for(int j=2*i;j<=maxn;j+=i)//求合数的欧拉函数值
            {
                if(!prim[j])
                    prim[j]=j;//对于遇到第一个因子的合数,先把他的欧拉函数值赋值为他本身,这是因为欧拉函数里面需要乘以本身
                prim[j]=prim[j]/i*(i-1);//遇到一个因子就*(1-1/n)
            }
        }
    }
    for(int i=3;i<=maxn;i++)//打表
        prim[i]+=prim[i-1];
}
int main()
{
    solve();
    while(scanf("%d",&n)!=EOF&&n)
    {
        printf("%lld\n",prim[n]);
    }
}
 

猜你喜欢

转载自blog.csdn.net/stdio_xuege/article/details/81216533