ACM1000,1001,1002: A+B问题

这三道题都属于比较基础简单的题目,按照每道题的要求写就可以了。

1000:

Description

Your task is to Calculate a + b.

Input

Input contains multiple test cases. Each test case consists of a pair of integers a and b ( 0 <= ab <= 20 ), separated by a space, one pair of integers per line.

Output

For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input.

Sample Input

1 1

Sample Output

2

代码如下:

#include<stdio.h>
int main()
{
	int a, b;
	while((scanf("%d%d", &a, &b)) != EOF)
	printf("%d\n", a + b);
	return 0;
}

1001:


Description

Your task is to Calculate a + b.

Input

There are multiple test cases. Each test case contains only one line. Each line consists of a pair of real number a and b(0<=a,b<=1000000), separated by a space.

Output

For each case, output the answer in one line rounded to 4 digits after the decimal point.

Sample Input

1 5
10 20
0.1 1.5

Sample Output

6.0000
30.0000
1.6000

代码如下:

#include<stdio.h>
int main()
{
	double a, b;
	while((scanf("%lf%lf", &a, &b)) != EOF)
	{
		printf("%.4lf\n", a + b);
	}
	return 0;
}

1002:


Description

Your task is to Calculate a + b.

Input

There are multiple test cases. Each test case contains only one line. Each line consists of a pair of integers a and b ( 1 <= ab<=1016 ) , separated by a space. Input is followed by a single line with a = 0, b = 0, which should not be processed.

Output

For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input.

Sample Input

1 5
10 20
10000000000000000 10000000000000000
0 0

Sample Output

6
30
20000000000000000

代码如下:

#include <iostream>
#include <math.h>
#include <stdlib.h>
using namespace std ;
 
long long int getNum(string s){
    long long int num = 0 ;
    int flag = 1 ;
    if (s[0]=='-') 
		flag = -1 ;
    for (int i = 0 ; i < s.length() ; ++i){
            if (abs(s[i]-'4')<=5){
                num+=(s[i]-'0') ;
                num *= 10 ;
            }
    }
    return flag*(num/10) ;
}

int main(){
    string a ,b ;
    while (cin>>a>>b){
    	if(getNum(a) != 0 && getNum(b) != 0){
    		cout<< getNum(a)+getNum(b)<<endl;
		}
        
    }
	return 0;
}

如果大家有更加简洁的代码,欢迎评论交流

猜你喜欢

转载自blog.csdn.net/qq_41681675/article/details/81214812
今日推荐