二叉树已知 先序 中序 求后序遍历序列

Tree

描述
Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes. 
This is an example of one of her creations: 
                                                D

                                              / \

                                             /   \

                                            B     E

                                           / \     \

                                          /   \     \

                                         A     C     G

                                                    /

                                                   /

                                                  F

To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree). For the tree drawn above the preorder traversal is DBACEGF and the inorder traversal is ABCDEFG. 
She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it). 

Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree. 
However, doing the reconstruction by hand, soon turned out to be tedious. 
So now she asks you to write a program that does the job for her! 
输入
The input will contain one or more test cases. 
Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.) 
Input is terminated by end of file.
输出
For each test case, recover Valentine's binary tree and print one line containing the tree's postorder traversal (left subtree, right subtree, root).
样例输入
DBACEGF ABCDEFG
BCAD CBAD
样例输出
ACBFGED
CDAB

#include<iostream>
#include<cstdio>
#include<cstring>
#include<stdlib.h>
using namespace std;
char str1[1005], str2[1005];
int n, Index;
struct node{
	char data;
	node *left, *right;
};

void Created(node* &T, int l, int r){
	if(l > r){
		return ;
	}
	T = (node *)malloc(sizeof(node));
	T->data = str1[Index];
	T->left = NULL;
	T->right = NULL;
	Index++;
	for(int i = l; i <= r; i++){
		if(str2[i] == str1[Index - 1]){
			Created(T->left, l, i - 1);
			Created(T->right, i + 1, r);
			break;
		}
	}
}

void Print(node *T){
	if(T != NULL){
		Print(T->left);
		Print(T->right);
		printf("%c", T->data);
	}
}

int main()
{
	while(scanf("%s%s", str1, str2) != EOF){
		n = strlen(str1);
		node *Tree;
		Index = 0;
		Created(Tree, 0, n - 1);
		Print(Tree);
		printf("\n");
	}
	return 0;
}
/*

DBACEGF ABCDEFG
BCAD CBAD


ACBFGED
CDAB

*/


猜你喜欢

转载自blog.csdn.net/sxh759151483/article/details/80632317