Swaps and Inversions(树状数组求逆序数)

Problem Description

Long long ago, there was an integer sequence a.
Tonyfang think this sequence is messy, so he will count the number of inversions in this sequence. Because he is angry, you will have to pay x yuan for every inversion in the sequence.
You don't want to pay too much, so you can try to play some tricks before he sees this sequence. You can pay y yuan to swap any two adjacent elements.
What is the minimum amount of money you need to spend?
The definition of inversion in this problem is pair (i,j) which 1≤i<j≤n and ai>aj.


Input

There are multiple test cases, please read till the end of input file.
For each test, in the first line, three integers, n,x,y, n represents the length of the sequence.
In the second line, n integers separated by spaces, representing the orginal sequence a.
1≤n,x,y≤100000, numbers in the sequence are in [−109,109]. There're 10 test cases.


Output

For every test case, a single integer representing minimum money to pay.


Sample Input

3 233 666
1 2 3
3 1 666
3 2 1


Sample Output

0
3

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
const int mod = 1e9+7;

struct node{
	ll data;
	int w;
}a[100005];
ll c[100005], x, y;

int b[100005], n;
ll lowbit(ll k){return k&(-k);}
void update(int t) {
    for (int i = t; i <= n; i += lowbit(i))
        c[i] += 1;
}
ll query(ll k){ll ans = 0;while(k){ans += c[k];k -= lowbit(k);}return ans;}

int cmp(node x, node y){
	return x.data < y.data;
}

int main(){
	while(scanf("%d%lld%lld", &n, &x, &y) != EOF){
		memset(c, 0, sizeof(c));
		for(int i = 1; i <= n; i++){
			scanf("%lld", &a[i].data);
			a[i].w = i;
		}
		sort(a + 1, a + n + 1, cmp);
		//离散化 
		int k = 0;
		for(int i = 1; i <= n; i++){
			if(a[i].data != a[i - 1].data)
				k++;
			b[a[i].w] = k;
		}
		//求逆序数 
		ll ans = 0;
		for(int i = 1; i <= n; i++){
			update(b[i]);
			ans += i - query(b[i]);
		}
		printf("%lld\n", ans * min(x, y));
	}
    return 0;
}

猜你喜欢

转载自blog.csdn.net/sxh759151483/article/details/81213809