B - Maximum Sum

题目:

A problem that is simple to solve in one dimension is often much more difficult to solve in more than one dimension. Consider satisfying a boolean expression in conjunctive normal form in which each conjunct consists of exactly 3 disjuncts. This problem (3-SAT) is NP-complete. The problem 2-SAT is solved quite efficiently, however. In contrast, some problems belong to the same complexity class regardless of the dimensionality of the problem.

Given a 2-dimensional array of positive and negative integers, find the sub-rectangle with the largest sum. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the subrectangle with the largest sum is referred to as the maximal sub-rectangle. A sub-rectangle is any contiguous sub-array of size 1 × 1 or greater located within the whole array. As an example, the maximal sub-rectangle of the array: 

0 −2 −7 0

9 2 −6 2

−4 1 −4 1

−1 8 0 −2

is in the lower-left-hand corner:

9 2

−4 1

−1 8

and has the sum of 15.

扫描二维码关注公众号,回复: 2411465 查看本文章

Input

The input consists of an N × N array of integers. The input begins with a single positive integer N on a line by itself indicating the size of the square two dimensional array. This is followed by N2 integers separated by white-space (newlines and spaces). These N2 integers make up the array in row-major order (i.e., all numbers on the first row, left-to-right, then all numbers on the second row, left-to-right, etc.). N may be as large as 100. The numbers in the array will be in the range [−127, 127]

Output

The output is the sum of the maximal sub-rectangle.

Sample Input

4 0 -2 -7

0 9 2 -6

2 -4 1 -4

1 -1 8 0 -2

Sample Output

15

题意:

给你一个矩阵,让你求出矩阵中和最大的值。

代码如下:

#include<stdio.h>
#include<string.h>

int n,a[200][200];//储存矩阵;
int sum[200];

int main()
{
    while(~scanf("%d",&n))
    {
        int i,j,k,h;
        for(i=0;i<n;i++)
        {
            for(j=0;j<n;j++)
            {
                scanf("%d",&a[i][j]);
            }
        }
        int min=-99999999;//极小化;
        for(i=0;i<n;i++)
        {
            memset(sum,0,sizeof sum);
            for(j=i;j<n;j++)
            {
                h=0;
                for(k=0;k<n;k++)
                {
                    sum[k]+=a[j][k];
                    if(h>=0)//如果和小于0就不用接着算了;
                        h+=sum[k];//很像数列求和的方法;
                    else
                        h=sum[k];
                    if(h>min)//储存最大的值;
                        min=h;
                }
            }
        }
        printf("%d\n",min);
    }
    return 0;
}


 

猜你喜欢

转载自blog.csdn.net/titi2018815/article/details/81156189