F - Fire Net

题目:

Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall. 

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening. 

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets. 

The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through. 

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways. 



Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration. 

Input

The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a '.' indicating an open space and an uppercase 'X' indicating a wall. There are no spaces in the input file.

Output

For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration. 

Sample Input

4
.X..
....
XX..
....
2
XX
.X
3
.X.
X.X
.X.
3
...
.XX
.XX
4
....
....
....
....
0

Sample Output

5
1
5
2
4

题意:

给你一个数字,代表地图的大小,然后知道每一个炮台它可以攻击到它的四个方向,但是炮弹不可以穿过障碍物,让你求出覆盖整个地图所需要的最少的炮台数。

代码如下:

扫描二维码关注公众号,回复: 2411459 查看本文章
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

int n,sum;
char map[11][11];

int check(int x,int y)
{
    for(int i=x-1; i>=0; i--)//同行;
    {
        if(map[i][y]=='X')//碰到障碍物,终止;
            break;
        else if(map[i][y]=='O')//foeze否则,变成O,代表被覆盖了;
            return 0;
    }
    for(int i=y-1; i>=0; i--)//同列;
    {
        if(map[x][i]=='X')
            break;
        else if(map[x][i]=='O')
            return 0;
    }
    return 1;
}

void dfs(int p,int q)
{
    if(p==n*n)
    {
        if(q>sum)
        {
            sum=q;
        }
        return;
    }
    else
    {
        int x=p/n,y=p%n;
        if(map[x][y]=='.'&&check(x,y)==1)
        {
            map[x][y]='O';
            dfs(p+1,q+1);
            map[x][y]='.';
        }
        dfs(p+1,q);
    }
}

int main()
{
    while(~scanf("%d",&n),n)
    {
        for(int i=0; i<n; i++)
        {
            scanf("%s",map[i]);
        }
        sum=0;
        dfs(0,0);
        printf("%d\n",sum);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/titi2018815/article/details/81156474