Fire Net

Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall. 

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening. 

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets. 

The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through. 

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways. 
 



Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration. 

Input

The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a '.' indicating an open space and an uppercase 'X' indicating a wall. There are no spaces in the input file.

Output

For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration. 

Sample Input

4
.X..
....
XX..
....
2
XX
.X
3
.X.
X.X
.X.
3
...
.XX
.XX
4
....
....
....
....
0

Sample Output

5
1
5
2
4

题意:给定一个最大为4的正方形图,可以在图中“.”处可以安防一个碉堡,每个碉堡会往它的四个方向发射一枚炮弹,炮弹会一直往前走,可以摧毁路上遇到的碉堡,但不能击穿墙,问这个图中最多能安放多少个碉堡?

思路:由于这个图的大小非常小,代码如下:因此我们可以尝试在每个点上都安放一个碉堡,最后求出一次最多能安防多少个。

#include<cstdio>
#include<cstring>
int n,maxx;
char str[10][10];
int check(int x,int y)//判断这个点能不能放碉堡
{
    int i,j,flag=1;
    for(i=x-1;i>=0;i--)    //判断这个点的四个方向
    {
        if(str[i][y]=='X')
            break;
        if(str[i][y]=='Y')
            {
                flag=0;
                break;
            }
    }
    if(!flag)
        return 0;
    for(i=x+1;i<n;i++)
    {
        if(str[i][y]=='X')
            break;
        if(str[i][y]=='Y')
            {
                flag=0;
                break;
            }
    }
    if(!flag)
        return 0;
    for(i=y-1;i>=0;i--)
    {
        if(str[x][i]=='X')
            break;
        if(str[x][i]=='Y')
            {
                flag=0;
                break;
            }
    }
    if(!flag)
        return 0;
    for(i=y+1;i<n;i++)
    {
        if(str[x][i]=='X')
            break;
        if(str[x][i]=='Y')
            {
                flag=0;
                break;
            }
    }

    if(!flag)
        return 0;
    return 1;
}
void dfs(int x)
{
    int flag=1;
    //printf("%d\n",x);
    for(int i=0;i<n;i++)
    {
        for(int j=0;j<n;j++)
        {
            if(str[i][j]=='.'&&check(i,j)) //这个点必须是 ‘.’,且符合不会打到其他碉堡
            {
                flag=0;
                str[i][j]='Y';
                dfs(x+1);
                str[i][j]='.';
            }
        }
    }
    if(flag)  //如果没有一个符合条件,也就是说这种情况下已经是最大值了
    {
        if(x>maxx)
            maxx=x;
    }
}
int main()
{
    while(~scanf("%d",&n)&&n)
    {
        for(int i=0;i<n;i++)
            scanf("%s",str[i]);
        maxx=0;
        dfs(0);
        printf("%d\n",maxx);
    }
}

猜你喜欢

转载自blog.csdn.net/qq_41890797/article/details/81158467