hdu-1001

Sum Problem
Time Limit: 1000/500 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 556225    Accepted Submission(s): 140960


Problem Description
Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).

In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.
 

Input
The input will consist of a series of integers n, one integer per line.
 

Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.
 

Sample Input
1
100
 

Sample Output
1

5050
 

Author
DOOM III
 

Recommend
We have carefully selected several similar problems for you:  1002 1090 1003 1091 1004 
 

心得:注意格式

扫描二维码关注公众号,回复: 2392316 查看本文章
#include<bits/stdc++.h>
using namespace std;

int main(void)
{
	int n,i;
	while(~scanf("%d",&n))
	{
		int sum=0;
		for(i=1;i<=n;i++)
		sum+=i;
		printf("%d\n\n",sum);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41829060/article/details/81152696
今日推荐