HDU-1041 -Computer Transformation

Computer Transformation

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8831    Accepted Submission(s): 3331


Problem Description
A sequence consisting of one digit, the number 1 is initially written into a computer. At each successive time step, the computer simultaneously tranforms each digit 0 into the sequence 1 0 and each digit 1 into the sequence 0 1. So, after the first time step, the sequence 0 1 is obtained; after the second, the sequence 1 0 0 1, after the third, the sequence 0 1 1 0 1 0 0 1 and so on.

How many pairs of consequitive zeroes will appear in the sequence after n steps?
 

Input
Every input line contains one natural number n (0 < n ≤1000).
 

Output
For each input n print the number of consecutive zeroes pairs that will appear in the sequence after n steps.
 

Sample Input
 
  
23
 
Sample Output
 
  
11
 

f[n]=2*f[n-2]+f[n-1]

import java.util.*;
import java.math.*;
public class Main
{
	BigInteger []f=new BigInteger[1005];
	public static void main(String args[])
	{new Main().run();}
	public void run()
	{
		Scanner cin=new Scanner(System.in);
		while(cin.hasNextInt())
		{
			int n=cin.nextInt();
			f[1]=BigInteger.valueOf(0);
			f[2]=BigInteger.valueOf(1);
			BigInteger b=BigInteger.valueOf(2);
			for(int i=3;i<=1000;i++)
			{
				BigInteger a=f[i-2];
				f[i]=a.multiply(b).add(f[i-1]);
			}
			System.out.println(f[n]);
		}
	}
}

猜你喜欢

转载自blog.csdn.net/xiaoyao_zhang/article/details/80032956