ACM——hdu1001(等差数列求和)

Problem Description
In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + … + n.

Input
The input will consist of a series of integers n, one integer per line

Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.

Sample Input
1 100

Sample Output
1 5050


这道题真心坑,我一开始想到的是用高斯求和的方法,也就是等差数列求和,d=1的情况。由于我误会有两个输入,所以表达式就是sum=(m+n)*(n-m+1)/2,但是题目的意思应该是每一行只输入一个整数n,计算1累加到n的总和,因此将上式的m赋值为1,得出公式为sum=(n+1)*n/2,当我欣喜地发现是我理解错题目并submit后,总是WA,我也是很心痛的。

#include <stdio.h>
int main() {
    int m,n;
    while(scanf("%d",&m)!=EOF)
    {
            scanf("%d",&n);
            printf("%d\n",(m+n)*(n-m+1)/2);
    }
    return 0;

}

找了很久的错误,发现题目中有一句要求是求和结果是32位有符号整数。那么问题来了,结果(n+1)*n/2一定是32位整数范围内的,但是(n+1)*n就不一定了。因此我们可以先除再乘来解决这个问题。修改后的代码如下:
Submission

#include<stdio.h>
int main()
{
    int n,sum;
    while(scanf("%d",&n)!=EOF)
    {
        if(n%2==0)
            sum=n/2*(n+1);
         else
            sum=(n+1)/2*n;
        printf("%d\n\n",sum);
    }
    return 0;
}

还有一种方法就是采用累加法,是可以AC的,如下:

#include<stdio.h>

int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        int i;
        int sum=0;
        for(i=1;i<=n;i++)
        sum+=i;
        printf("%d\n\n",sum);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/marilynmontu/article/details/81144265
今日推荐