POJ - 2018 Best Cow Fences (二分 连续数的平均和+前缀和)

Farmer John’s farm consists of a long row of N (1 <= N <= 100,000)fields. Each field contains a certain number of cows, 1 <= ncows <= 2000.

FJ wants to build a fence around a contiguous group of these fields in order to maximize the average number of cows per field within that block. The block must contain at least F (1 <= F <= N) fields, where F given as input.

Calculate the fence placement that maximizes the average, given the constraint. 
Input 
* Line 1: Two space-separated integers, N and F.

Lines 2..N+1: Each line contains a single integer, the number of cows in a field. Line 2 gives the number of cows in field 1,line 3 gives the number in field 2, and so on. 
Output
Line 1: A single integer that is 1000 times the maximal average.Do not perform rounding, just print the integer that is 1000*ncows/nfields. 
Sample Input 
10 6 



10 






Sample Output 
6500 

题意:给出一个数组,寻找一段连续和,使得其平均和最大,但是长度不可以小于F

思路:平均和肯定是单调的,所以我们二分平均和,然后将每个数都减去这二分的数,然后统计序列的和的是不是正数,长度是否大于F。

#include<iostream>
#include<cstdio>
#include<vector>
#define maxx 400005
using namespace std;
double a[100005];
double b[100005];
double c[100005];
int main()
{

        int n;
        int f;
        cin>>n>>f;
        for(int i=1;i<=n;i++)
            scanf("%lf",a+i);
        double eps=1e-5;
        double l=-1e6,r=1e6;
        while(r-l>eps)   //二分平均值
        {
            double mid=(l+r)/2;
            for(int i=1;i<=n;i++)
                b[i]=a[i]-mid;
            for(int i=1;i<=n;i++)
                c[i]=c[i-1]+b[i];//求前缀和,
            double ans=-1e10;
            double minn=1e10;
            for(int i=f;i<=n;i++)
            {
                minn=min(minn, c[i-f]);//不断维护左端的最小值
                ans=max(ans, c[i]-minn);//相减得到区间和,不断往正值靠近
            }             
            if(ans>=0)  //实数域上的二分
                l=mid;
            else
                r=mid;
        }
        cout<<(int)(r*1000);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/deepseazbw/article/details/81180481