POJ 2018 Best Cow Fences(构造下凸折线)

Best Cow Fences
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 12527   Accepted: 4063

Description

Farmer John's farm consists of a long row of N (1 <= N <= 100,000)fields. Each field contains a certain number of cows, 1 <= ncows <= 2000. 

FJ wants to build a fence around a contiguous group of these fields in order to maximize the average number of cows per field within that block. The block must contain at least F (1 <= F <= N) fields, where F given as input. 

Calculate the fence placement that maximizes the average, given the constraint. 

Input

* Line 1: Two space-separated integers, N and F. 

* Lines 2..N+1: Each line contains a single integer, the number of cows in a field. Line 2 gives the number of cows in field 1,line 3 gives the number in field 2, and so on. 

Output

* Line 1: A single integer that is 1000 times the maximal average.Do not perform rounding, just print the integer that is 1000*ncows/nfields. 

Sample Input

10 6
6 
4
2
10
3
8
5
9
4
1

Sample Output

6500

#include<cstdio>
#include<algorithm>
using namespace std;
#define ll long long
const int maxn=1e5+10;
int a[maxn],deq[maxn];
ll sum[maxn];
bool check(int i,int j,int x,int y)
{
    return (sum[j]-sum[i])*(y-x)>=(sum[y]-sum[x])*(j-i);
}
int main()
{
    int n,f;
    scanf("%d%d",&n,&f);
    for(int i=1;i<=n;i++)
        scanf("%d",&a[i]);
    for(int i=1;i<=n;i++)
        sum[i]=sum[i-1]+a[i];
    int s=0,t=0;
    deq[t++]=0;
    ll ma=0;
    for(int i=f;i<=n;i++)
    {
        while(s<t-1&&check(deq[s+1],i,deq[s],i))s++;
        ma=max(ma,1000*(sum[i]-sum[deq[s]])/(i-deq[s]));
        while(s<t-1&&check(deq[t-2],deq[t-1],deq[t-1],i-f+1)) t--;
        deq[t++]=i-f+1;
    }
    printf("%I64d\n",ma);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/albertluf/article/details/81042519