Best Cow Fences 二分

问题 K: Best Cow Fences

时间限制: 1 Sec  内存限制: 128 MB
提交: 25  解决: 11
[提交] [状态] [讨论版] [命题人:admin]

题目描述

Farmer John's farm consists of a long row of N (1 <= N <= 100,000)fields. Each field contains a certain number of cows, 1 <= ncows <= 2000. 
FJ wants to build a fence around a contiguous group of these fields in order to maximize the average number of cows per field within that block. The block must contain at least F (1 <= F <= N) fields, where F given as input. 
Calculate the fence placement that maximizes the average, given the constraint. 

输入

* Line 1: Two space-separated integers, N and F. 
* Lines 2..N+1: Each line contains a single integer, the number of cows in a field. Line 2 gives the number of cows in field 1,line 3 gives the number in field 2, and so on. 

输出

* Line 1: A single integer that is 1000 times the maximal average.Do not perform rounding, just print the integer that is 1000*ncows/nfields. 

样例输入

10 6
6 
4
2
10
3
8
5
9
4
1

样例输出

6500

求最大平均数,长度不小于k的连续子串
如果先减去平均值,就转变为求一个长度不小于k且非负的连续子串

 利用前缀和相减的形式计算

double minn=INF,ans=-INF;
        for(int i=k; i<=n; i++){
            minn=min(minn,sum[i-k]);
            ans=max(ans,sum[i]-minn);
        }
因为一段数的平均数不会大于这些数里的最大值,不会小于最小值,所以利用二分来计算平均值


代码:
#include <bits/stdc++.h>
using namespace std;
const int maxx=1e5+100;
const int INF=1e10;
const int MOD=1e9+7;
typedef long long ll;
double a[maxx];
double b[maxx],sum[maxx];
int main()
{
    int n,k;
    double l=INF,r=0;
    scanf("%d%d",&n,&k);
    for(int i=1; i<=n; i++){
        scanf("%lf",&a[i]);
        l=min(l,a[i]);
        r=max(r,a[i]);
    }
    //l=-1e6;
    //r=1e6;
    while(r-l>1e-5){
        double mid=(l+r)/2;
        for(int i=1; i<=n; i++)  b[i]=a[i]-mid;
        for(int i=1; i<=n; i++)  sum[i]=sum[i-1]+b[i];
        double minn=INF,ans=-INF;
        for(int i=k; i<=n; i++){
            minn=min(minn,sum[i-k]);
            ans=max(ans,sum[i]-minn);
        }
        if(ans>=0)  l=mid;
        else  r=mid;
    }
    cout<<int(r*1000)<<endl;
    return 0;
}

猜你喜欢

转载自blog.csdn.net/renzijing/article/details/81148584