poj2531(二进制枚举/位向量构造dfs)

题目链接:http://poj.org/problem?id=2531


Network Saboteur
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 14239   Accepted: 6991

Description

A university network is composed of N computers. System administrators gathered information on the traffic between nodes, and carefully divided the network into two subnetworks in order to minimize traffic between parts.
A disgruntled computer science student Vasya, after being expelled from the university, decided to have his revenge. He hacked into the university network and decided to reassign computers to maximize the traffic between two subnetworks.
Unfortunately, he found that calculating such worst subdivision is one of those problems he, being a student, failed to solve. So he asks you, a more successful CS student, to help him.
The traffic data are given in the form of matrix C, where Cij is the amount of data sent between ith and jth nodes (Cij = Cji, Cii = 0). The goal is to divide the network nodes into the two disjointed subsets A and B so as to maximize the sum ∑Cij (i∈A,j∈B).

Input

The first line of input contains a number of nodes N (2 <= N <= 20). The following N lines, containing N space-separated integers each, represent the traffic matrix C (0 <= Cij <= 10000).
Output file must contain a single integer -- the maximum traffic between the subnetworks.

Output

Output must contain a single integer -- the maximum traffic between the subnetworks.

Sample Input

3
0 50 30
50 0 40
30 40 0

Sample Output

90

思路:这其实是一道水题,但是我写的方法太慢了,又参考了别的博客上的写法,发现速度差了很多,于是重做了这题,顺便看了一下dfs中的位向量构造。之前还真的是没用过。唉(╥╯^╰╥),全是漏洞啊!

这个是我之前写的代码,用的二进制枚举

#include<cstdio>
#include<algorithm>
int a[25][25];
int mp[5000000];
using namespace std;
int main()
{
	int n;
	scanf("%d",&n);
	int d=1;
	for(int i=1;i<=20;i++)
	{
		mp[d]=i;
		d*=2;
	}
	for(int i=1;i<=n;i++)
    {
    	for(int j=1;j<=n;j++)
    	{
    		scanf("%d",&a[i][j]);
		}
	}
	int ans;
	int b,c;
	int maxn=-1;
	for(int i=1;i<((1<<n)-1);i++)
	{
		ans=0;
		b=1;
		while(b<=i)
		{
			if(b&i)
			{
				 c=1;
				 while(c<=i)
				 {
				 	 if(!(c&i))
				 	{
				 	    ans+=a[mp[b]][mp[c]];	
					}
					c <<= 1;
				 }
			}
			b <<= 1;
		}
		maxn=max(maxn,ans);
	}
	printf("%d\n",maxn);
	return 0;
}

结果。。。

         

这道题是2s,可以说基本T了

而位向量法

#include<cstdio>
#include<algorithm>
using namespace std; 
int m[25][25];
int n;
int a[25];
int b[25];
int maxn;
int maxset(int na,int nb)
{
	int sum=0;
	for(int i=0;i<na;i++)
	{
		for(int j=0;j<nb;j++)
		{
			sum+=m[a[i]][b[j]];
		}
	}
	return sum;
}
void dfs(int cur,int na,int nb)
{
	if(cur==n+1)
	{
		maxn=max(maxset(na,nb),maxn);
		return ;
	}
	a[na]=cur;
	dfs(cur+1,na+1,nb);
	b[nb]=cur;
	dfs(cur+1,na,nb+1);
}
int main()
{
	scanf("%d",&n);
	for(int i=1;i<=n;i++)
    {
    	for(int j=1;j<=n;j++)
    	{
    		scanf("%d",&m[i][j]);
		}
	}
	maxn=-1;
	dfs(1,0,0);
	printf("%d\n",maxn);
	return 0;
}

这次。。。

           

还是窝太菜了 ()


猜你喜欢

转载自blog.csdn.net/star_moon0309/article/details/80776175