POJ2965 二进制枚举问题

目录:2020年8月16日21:41:57

题目:

The game “The Pilots Brothers: following the stripy elephant” has a quest where a player needs to open a refrigerator.

There are 16 handles on the refrigerator door. Every handle can be in one of two states: open or closed. The refrigerator is open only when all handles are open. The handles are represented as a matrix 4х4. You can change the state of a handle in any location [i, j] (1 ≤ i, j ≤ 4). However, this also changes states of all handles in row i and all handles in column j.

The task is to determine the minimum number of handle switching necessary to open the refrigerator.

Input

The input contains four lines. Each of the four lines contains four characters describing the initial state of appropriate handles. A symbol “+” means that the handle is in closed state, whereas the symbol “−” means “open”. At least one of the handles is initially closed.

Output

The first line of the input contains N – the minimum number of switching. The rest N lines describe switching sequence. Each of the lines contains a row number and a column number of the matrix separated by one or more spaces. If there are several solutions, you may give any one of them.

Sample Input

- + - -
- - - -
- - - -
- + - -

Sample Output

6
1 1
1 3
1 4
4 1
4 3
4 4

题意:

个冰箱上有4*4共16个开关,改变任意一个开关的状态(即开变成关,关变成开)时,此开关的同一行、同一列所有的开关都会自动改变状态。要想打开冰箱,要所有开关全部打开才行。 输入:一个4×4的矩阵,+表示关闭,-表示打开; 输出:使冰箱打开所需要执行的最少操作次数,以及所操作的开关坐标。

分析

利用枚举来寻找最短路径

#include <iostream>
#include <vector>
using namespace std;

typedef pair<int,int> PII;
vector<PII> path,ans;

string s;
int state = 0;
int a[4][4];

void init(){
	for(int i = 0; i < 4; i++){
		for(int j = 0; j < 4; j++){
			for(int k = 0; k < 4; k++){
				a[i][j] += 1 << (i * 4 + k);
				a[i][j] += 1 << (k * 4 + j);
			}
			a[i][j] -= 1 << (i * 4 + j);
		}
	}
}

void bp(int p){
	int t = state;
	path.clear();
	
	for(int i = 0; i < 16; i++){
		if((p >> i) & 1){
			int x = i / 4;
			int y = i % 4;
			PII tem;
			tem.first = x;
			tem.second = y;
			path.push_back(tem);
			
			t ^= a[x][y];	
		}
	}
	if(t == 0) {
		if(ans.empty() || ans.size() > path.size()){
			ans = path;
		}
	}
}

void print(){
	cout<<ans.size()<<endl;
	for(int i = 0; i < ans.size(); i++){
		cout<<ans[i].first + 1<<" "<<ans[i].second + 1<<endl;
	}
}

int main(){
	init();
	for(int i = 0; i < 4; i++){
		cin>>s;
		for(int j = 0; j < 4 ; j++){
			if(s[j] == '+') state = state+( 1<< (i*4 + j));
		} 
	}

	
	for(int p = 0; p < (1 << 16); p++) bp(p);
	
	print();
}

猜你喜欢

转载自blog.csdn.net/qq_44923545/article/details/107954808
今日推荐