Machine(模拟)

There is a machine with m(2≤m≤30)m(2≤m≤30) coloured bulbs and a button.When the button is pushed, the rightmost bulb changes. 
For any changed bulb, 

if it is red now it will be green; 

if it is green now it will be blue; 

if it is blue now it will be red and the bulb that on the left(if it exists) will change too. 

Initally all the bulbs are red. What colour are the bulbs after the button be 
pushed n(1≤n<263)n(1≤n<263) times?

Input

There are multiple test cases. The first line of input contains an integer T(1≤T≤15)T(1≤T≤15) indicating the number of test cases. For each test case: 

The only line contains two integers m(2≤m≤30)m(2≤m≤30) and n(1≤n<263)n(1≤n<263).

Output

For each test case, output the colour of m bulbs from left to right. 
R indicates red. G indicates green. B indicates blue.

Sample Input

2
3 1
2 3

Sample Output

RRG
GR

分析:由题意知道,按一次变成G,按两次变成B,按三次变成R,相当于取模运算,从最后一位开始存储n%3的值,每向前移动一位就给n/3。不过刚开始数组要初始化为0;刚开始我给数组存的是字符,但是数字大了以后打印的时候会出现乱码,所以最后就考虑存储数字了。

#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;
int  color[32];
int main()
{
    long long n;
    int m;
    int T;

    scanf("%d",&T);
    while(T--)
    {
        memset(color,0,sizeof(color));
        int i=1;
        scanf("%d%lld",&m,&n);
        while(n)
        {
           color[m-i]=n%3;
            n=n/3;
            i++;
        }
        //cout<<endl;/*
        for(int i=0;i<m;i++)
           {
               if(color[i]==0)printf("R");
               else if(color[i]==1)printf("G");
               else if(color[i]==2)printf("B");
           }
            printf("\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/guagua_de_xiaohai/article/details/81154959