Redundant Paths POJ - 3177

In order to get from one of the F (1 <= F <= 5,000) grazing fields (which are numbered 1..F) to another field, Bessie and the rest of the herd are forced to cross near the Tree of Rotten Apples. The cows are now tired of often being forced to take a particular path and want to build some new paths so that they will always have a choice of at least two separate routes between any pair of fields. They currently have at least one route between each pair of fields and want to have at least two. Of course, they can only travel on Official Paths when they move from one field to another. 

Given a descri_ption of the current set of R (F-1 <= R <= 10,000) paths that each connect exactly two different fields, determine the minimum number of new paths (each of which connects exactly two fields) that must be built so that there are at least two separate routes between any pair of fields. Routes are considered separate if they use none of the same paths, even if they visit the same intermediate field along the way. 

There might already be more than one paths between the same pair of fields, and you may also build a new path that connects the same fields as some other path.
Input
Line 1: Two space-separated integers: F and R 

Lines 2..R+1: Each line contains two space-separated integers which are the fields at the endpoints of some path.
Output
Line 1: A single integer that is the number of new paths that must be built.
Sample Input
7 7
1 2
2 3
3 4
2 5
4 5
5 6
5 7
Sample Output
2
Hint
Explanation of the sample: 

One visualization of the paths is: 
1   2   3
   +---+---+  
       |   |
       |   |
 6 +---+---+ 4
      / 5
     / 
    / 
 7 +
Building new paths from 1 to 6 and from 4 to 7 satisfies the conditions. 
1   2   3
   +---+---+  
   :   |   |
   :   |   |
 6 +---+---+ 4
      / 5  :
     /     :
    /      :
 7 + - - - - 
Check some of the routes: 
1 – 2: 1 –> 2 and 1 –> 6 –> 5 –> 2 
1 – 4: 1 –> 2 –> 3 –> 4 and 1 –> 6 –> 5 –> 4 
3 – 7: 3 –> 4 –> 7 and 3 –> 2 –> 5 –> 7
 
Every pair of fields is, in fact, connected by two routes. 

It's possible that adding some other path will also solve the problem (like one from 6 to 7). Adding two paths, however, is the minimum.

题目很好理解,具体做法就是求出桥,然后删除所有桥边,剩下的好多联通块,然后缩点,把桥边加上,变成一棵树,剩下所有度数为1的点的数量记为ans,加边的数量就是(ans+1)/2.

#include <cstdio>  
#include <cstdlib>  
#include <cstring>  
#include <iostream>  
#include <algorithm>  
  
using namespace std;  
  
const int N = 5010;  
const int M = 10010;  
  
struct node  
{  
    int next;  
    int to;   
	bool tag; 
}edge[M << 1];  
  
int head[N];  
int DFN[N];  
int low[N];  
bool instack[N];  
int block[N];    //存的是1~sccnum的数值,可以看出联通块 
int deg[N];    //存放各个联通块的度数 
int Stack[M];  
int tot, sccnum, ord,top,bridge;  
  
void addedge (int from, int to)  
{  
    edge[tot].to = to;  
    edge[tot].next = head[from];
	edge[tot].tag=false;  
    head[from] = tot++;  
}  
  
void init ()  
{  
    memset (DFN, -1, sizeof(DFN));  
    memset (low, 0, sizeof(low));  
    memset (instack, 0, sizeof(instack));  
    memset (deg, 0, sizeof(deg));  
    memset (head, -1, sizeof(head));  

    tot = sccnum = ord =top=bridge= 0;  
}  
  
void tarjan (int u,int fa)  
{  
    DFN[u] = low[u] = ++ord;  
    instack[u] = 1;  
    Stack[top++]=u; 
    for (int i = head[u]; i!=-1; i = edge[i].next)  
    {  
        int v = edge[i].to;  
        if(v==fa)
        {
        	continue;
		}
        if (DFN[v] == -1)  
        {  
            tarjan (v,u);  
            low[u] = min(low[u], low[v]);  
            if(low[v]>DFN[u])  //满足桥的条件 
            {
            	bridge++;
            	edge[i].tag=true;
            	edge[i^1].tag=true;
			}
        }  
        else if (instack[v])  
        {  
            low[u] = min(low[u], DFN[v]);  
        }  
    }  
    int v;  
    if (DFN[u] == low[u])  
    {  
        ++sccnum;  
        do  
        {  
            v=Stack[--top] ;
            instack[v] = 0;  
            block[v] = sccnum;  
        }while (v != u);  
    }  
}  
  
void solve (int n)  
{  
    for (int i = 1; i <= n; ++i)  
    {  
        if (DFN[i] == -1)  
        {  
            tarjan (i, -1);  
        }  
    }  
    for (int u = 1; u <= n; ++u)  
    {  
        for (int j = head[u]; ~j; j = edge[j].next)  
        {  
              
            if (edge[j].tag)  
            {  
                deg[block[u]]++; 
            }  
 
        }  
    }  
    int cnt = 0;  
    for (int i = 1; i <= sccnum; ++i)  
    {  
        if (deg[i] == 1)  
        {  
            ++cnt;  
        }  
    }  
    //printf("%d\n",bridge);
    printf("%d\n", (cnt + 1) / 2);  
}  
  
int main()  
{  
	//freopen("C:/input.txt", "r", stdin);
    int n, m;  
    int u, v;  
    while (~scanf("%d%d", &n, &m))  
    {  
        init();  
        for (int i = 1; i <= m; ++i)  
        {  
            scanf("%d%d", &u, &v);  
            addedge (u, v);  
            addedge (v, u);  
        }  
        solve(n);  
    }  
    return 0;  
}  
可以处理重边

猜你喜欢

转载自blog.csdn.net/evildoer_llc/article/details/80304781