乘法逆元 (51nod 1256)

给出2个数M和N(M < N),且M与N互质,找出一个数K满足0 < K < N且K * M % N = 1,如果有多个满足条件的,输出最小的。

Input

输入2个数M, N中间用空格分隔(1 <= M < N <= 10^9)

Output

输出一个数K,满足0 < K < N且K * M % N = 1,如果有多个满足条件的,输出最小的。

Sample Input

2 3

Sample Output

2

题解:扩展欧几里德模板题,扩展欧几里德常用在求解模线性方程及方程组中。然后为了防止x是负数,一直加n加到正数为止。

代码如下:

#include <iostream>
#include <cstdio>
#include <stdlib.h>
#include <cmath>
#include <cstring>
#include <algorithm>
#include <string.h>
#include <vector>
#include <queue>
#include <stack>
#include <set>
#include <map>
#include <ctime>
#define maxn 10007
#define N 107
#define INF 0x3f3f3f3f
#define PI acos(-1)
#define lowbit(x) (x&(-x))
#define eps 0.000000001
using namespace std;
typedef long long ll;
ll m,n,k;
void ex_gcd(ll a,ll b,ll &x,ll &y)
{
    if(b==0)
    {
        x=1;
        y=0;
        return;
    }
    ex_gcd(b,a%b,x,y);
    int tmp=x;
    x=y;
    y=tmp-(a/b)*y;
}
int main()
{
	int i,j,k;
	ll x,y;
	cin>>m>>n;
	ex_gcd(m,n,x,y);
	while(x<0)
	{
		x+=n;
	}
	printf("%d\n",x);
	return 0;
}

猜你喜欢

转载自blog.csdn.net/baiyi_destroyer/article/details/81132496
今日推荐