Little Boxes

Little boxes on the hillside.
Little boxes made of ticky-tacky.
Little boxes.
Little boxes.
Little boxes all the same.
There are a green boxes, and b pink boxes.
And c blue boxes and d yellow boxes.
And they are all made out of ticky-tacky.
And they all look just the same.
Input
The input has several test cases. The first line contains the integer t (1 ≤ t ≤ 10) which is the total number of test cases.
For each test case, a line contains four non-negative integers a, b, c and d where a, b, c, d ≤ 2^62, indicating the numbers of green boxes, pink boxes, blue boxes and yellow boxes.
Output
For each test case, output a line with the total number of boxes.
Sample Input
4
1 2 3 4
0 0 0 0
1 0 0 0
111 222 333 404
Sample Output
10
0
1
1070
这个题看似简单…实则有大坑,在题干信息中描述很清楚,为4个数字的加法求和,但是如果没有注意到数据范围,就会轻易地错,这个结果很明显,每个数字的数据上限是262次方,四个的话就是264次方,而longlong的数据上限是2^63-1,由于题干信息可以理解数据不会出现负数,所以我们用unsigned long long 解决数据上限问题,unsigned long long 的数据范围是2^64-1,没有包括最极端的情况,所以需要特判一下,这次就算对了

#include"cstdio"
#include"cstring"
#include"iostream"
#include"algorithm"
#include"stdlib.h"
using namespace std;
int main()
{
	int T;
	unsigned long long a,b,c,d;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%lld %lld %lld %lld",&a,&b,&c,&d);
		if(a==4611686018427387904&&b==4611686018427387904&&c==4611686018427387904&&d==4611686018427387904)
		{
			printf("18446744073709551616\n");
		}
		else
		{
			cout<<a+b+c+d<<endl;
		}	
	}
	return 0;
 } 
发布了76 篇原创文章 · 获赞 1 · 访问量 2765

猜你喜欢

转载自blog.csdn.net/weixin_44824383/article/details/104341002