HDU -- 1033

Edge
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4581 Accepted Submission(s): 2734

Problem Description
For products that are wrapped in small packings it is necessary that the sheet of paper containing the directions for use is folded until its size becomes small enough. We assume that a sheet of paper is rectangular and only folded along lines parallel to its initially shorter edge. The act of folding along such a line, however, can be performed in two directions: either the surface on the top of the sheet is brought together, or the surface on its bottom. In both cases the two parts of the rectangle that are separated by the folding line are laid together neatly and we ignore any differences in thickness of the resulting folded sheet.
After several such folding steps have been performed we may unfold the sheet again and take a look at its longer edge holding the sheet so that it appears as a one-dimensional curve, actually a concatenation of line segments. If we move along this curve in a fixed direction we can classify every place where the sheet was folded as either type A meaning a clockwise turn or type V meaning a counter-clockwise turn. Given such a sequence of classifications, produce a drawing of the longer edge of the sheet assuming 90 degree turns at equidistant places.

Input
The input contains several test cases, each on a separate line. Each line contains a nonempty string of characters A and V describing the longer edge of the sheet. You may assume that the length of the string is less than 200. The input file terminates immediately after the last test case.

Output
For each test case generate a PostScript drawing of the edge with commands placed on separate lines. Start every drawing at the coordinates (300, 420) with the command “300 420 moveto”. The first turn occurs at (310, 420) using the command “310 420 lineto”. Continue with clockwise or counter-clockwise turns according to the input string, using a sequence of “x y lineto” commands with the appropriate coordinates. The turning points are separated at a distance of 10 units. Do not forget the end point of the edge and finish each test case by the commands stroke and showpage.

You may display such drawings with the gv PostScript interpreter, optionally after a conversion using the ps2ps utility.

Sample Input
V
AVV

Sample Output
300 420 moveto
310 420 lineto
310 430 lineto
stroke
showpage
300 420 moveto
310 420 lineto
310 410 lineto
320 410 lineto
320 420 lineto
stroke
showpage
这道题刚开始没有做出来的主要问题的自己不知道怎么解决角度跟x,y的增量的问题,后来看了别人的博客学到了一种方法。

#include<cstdio>
#include<string>
#include<iostream>
using namespace std;

const int L = 0, R = 1, U = 2, D = 3; // 规定方向左右上下 
int dir_A[] = {U, D, R, L}; // 向右转后的方向,要记住原来的大方向不改变,
//即现在的右手是上方向 
int dir_V[] = {D, U, L, R}; // 这个跟上边的道理是一样的 
int dx[] = {-10, 10, 0, 0};
int dy[] = {0, 0, 10, - 10};

int main()
{
    string str;
    while(cin >> str)
    {
        cout<<"300 420 moveto"<<endl;
        cout<<"310 420 lineto"<<endl;
        int x = 310, y = 420;//初始方向 
        int init_dir = 1; // 初始角度都是先向右转 
        for(int i = 0; i < str.size(); i ++)
        {
            char str_c = str[i];
            int new_dir;
            if (str_c == 'A')
            {
                new_dir = dir_A[init_dir];
                x += dx[new_dir];
                y += dy[new_dir];
            }
            else
            {
                new_dir = dir_V[init_dir];
                x += dx[new_dir];
                y += dy[new_dir];
            }
            init_dir = new_dir;
            cout << x << " " << y << " lineto" << endl;
        }

        cout << "stroke" << endl;
        cout << "showpage" << endl;

    }
    return 0;
 } 

猜你喜欢

转载自blog.csdn.net/hqzzbh/article/details/81050679
今日推荐