【PAT】B1049/A1104. Sum of Number Segments (20)

Description:
Given a sequence of positive numbers, a segment is defined to be a consecutive subsequence. For example, given the sequence {0.1, 0.2, 0.3, 0.4}, we have 10 segments: (0.1) (0.1, 0.2) (0.1, 0.2, 0.3) (0.1, 0.2, 0.3, 0.4) (0.2) (0.2, 0.3) (0.2, 0.3, 0.4) (0.3) (0.3, 0.4) (0.4).

Now given a sequence, you are supposed to find the sum of all the numbers in all the segments. For the previous example, the sum of all the 10 segments is 0.1 + 0.3 + 0.6 + 1.0 + 0.2 + 0.5 + 0.9 + 0.3 + 0.7 + 0.4 = 5.0.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N, the size of the sequence which is no more than 10^5. The next line contains N positive numbers in the sequence, each no more than 1.0, separated by a space.

Output Specification:

For each test case, print in one line the sum of all the numbers in all the segments, accurate up to 2 decimal places.

Sample Input:
4
0.1 0.2 0.3 0.4 


Sample Output:
5.00

#pragma warning(disable:4996)
#include <stdio.h>
#include <stdlib.h>
int main(){
	int n;
	double dt[100010], sum = 0;
	scanf("%d", &n);
	for (int i = 1; i <= n; i++){
		scanf("%lf", &dt[i]);
		sum += dt[i] * i * (n - i + 1);
	}
	printf("%.2f\n", sum);
	system("pause");
	return 0;
}

这道题显然需要找规律。

猜你喜欢

转载自blog.csdn.net/ztmajor/article/details/81087357
今日推荐