PAT A 1104 Sum of Number Segments

Given a sequence of positive numbers, a segment is defined to be a consecutive subsequence. For example, given the sequence {0.1, 0.2, 0.3, 0.4}, we have 10 segments: (0.1) (0.1, 0.2) (0.1, 0.2, 0.3) (0.1, 0.2, 0.3, 0.4) (0.2) (0.2, 0.3) (0.2, 0.3, 0.4) (0.3) (0.3, 0.4) (0.4).

Now given a sequence, you are supposed to find the sum of all the numbers in all the segments. For the previous example, the sum of all the 10 segments is 0.1 + 0.3 + 0.6 + 1.0 + 0.2 + 0.5 + 0.9 + 0.3 + 0.7 + 0.4 = 5.0.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N, the size of the sequence which is no more than 10^5^. The next line contains N positive numbers in the sequence, each no more than 1.0, separated by a space.

Output Specification:

For each test case, print in one line the sum of all the numbers in all the segments, accurate up to 2 decimal places.

Sample Input:

4
0.1 0.2 0.3 0.4

Sample Output:

5.00

推一下,公式就是如下,但有一个问题,我把a放在连乘的右边,有两个测试点过不去,而在左边,都能过,why?

#include<cstdio>
main() {
    int n;
    scanf("%d", &n);
    double a, sum = 0;
    for (int i = 0; i < n; i++) {
        scanf("%lf", &a);
        sum += a*(n-i)*(i+1);//为什么把a放在右边不行??
    }
    printf("%.2f\n", sum);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/joah_ge/article/details/81056549
今日推荐