K-求末两位数字

一个整数,只知道前几位,不知道末二位,被另一个整数除尽了,那么该数的末二位该是什么呢?
Input输入数据有若干组,每组数据包含二个整数a,b(0<a<10000, 10<b<100),若遇到0 0则处理结束。Output对应每组数据,将满足条件的所有尾数在一行内输出,格式见样本输出。同组数据的输出,其每个尾数之间空一格,行末没有空格。Sample Input
200 40
1992 95
0 0
Sample Output
00 40 80
15

#include <iostream>
#include <cstdio>
int main() {
          int a,b,c;  
        while(scanf("%d%d",&a,&b)&&(a!=0||b!=0)) 
        {
c=0;
               a=a*100;
         for(int i=a;i<a+100;i++)
           if(i%b==0)
            {
                   if(c==0)
  {
                   printf("%.2d",i%100);
                      c++;
                  }
                else
                 printf(" %.2d",i%100);
            }
            printf("\n");
        }
return 0;
}

猜你喜欢

转载自blog.csdn.net/lioncatch/article/details/80677743