HDU1875 最小生成树 Kruskal

畅通工程再续

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 34620    Accepted Submission(s): 11481


Problem Description
相信大家都听说一个“百岛湖”的地方吧,百岛湖的居民生活在不同的小岛中,当他们想去其他的小岛时都要通过划小船来实现。现在政府决定大力发展百岛湖,发展首先要解决的问题当然是交通问题,政府决定实现百岛湖的全畅通!经过考察小组RPRush对百岛湖的情况充分了解后,决定在符合条件的小岛间建上桥,所谓符合条件,就是2个小岛之间的距离不能小于10米,也不能大于1000米。当然,为了节省资金,只要求实现任意2个小岛之间有路通即可。其中桥的价格为 100元/米。
 

Input
输入包括多组数据。输入首先包括一个整数T(T <= 200),代表有T组数据。
每组数据首先是一个整数C(C <= 100),代表小岛的个数,接下来是C组坐标,代表每个小岛的坐标,这些坐标都是 0 <= x, y <= 1000的整数。
 

Output
每组输入数据输出一行,代表建桥的最小花费,结果保留一位小数。如果无法实现工程以达到全部畅通,输出”oh!”.
 

Sample Input
 
   
2210 1020 2031 12 21000 1000
 

Sample Output
 
   
1414.2
oh!
#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;
int pre[10005];
int t;
int n;
int tot;
double ans;
int cnt;
int find(int x)
{
    int root=x;
    while(root!=pre[root])
    {
        root=pre[root];
    }

    int i=x;
    int farther;
    while(pre[i]!=i)
    {
        farther=pre[i];
        pre[i]=root;
        i=farther;
    }
    return root;
}
bool jion(int a,int b)
{
    int ra=find(a);
    int rb=find(b);
    if(ra!=rb)
    {
        pre[rb]=ra;
        return true;
    }
    return false;
}
struct site
{
    int x,y;
    int no;
}s[105];
struct path
{
    site from,to;
    double len;
}a[10005];
bool cmp (path t1,path t2)
{
    return t1.len<t2.len;
}
double dis(site t1,site t2)
{
    return sqrt((t1.x-t2.x)*(t1.x-t2.x)+(t1.y-t2.y)*(t1.y-t2.y));
}
void Kruskal()
{
    ans=0;
    cnt=0;
    sort(a,a+tot,cmp);
    for(int i=0;i<=tot;++i)
        pre[i]=i;
    for(int i=0;i<tot;++i)
        if(jion(a[i].from.no,a[i].to.no))
        {
            ans+=a[i].len;
            cnt++;//判断是否都连上了
        }
}
int main()
{
    cin>>t;
    while(t--)
    {
        tot=0;
        scanf("%d",&n);
        for(int i=0;i<n;++i)
            {
                scanf("%d%d",&s[i].x,&s[i].y);
                s[i].no=i+1;
            }
        for(int i=0;i<n;++i)
            for(int j=i+1;j<n;++j)
        {
            double l=dis(s[i],s[j]);
            if(l>1000||l<10) continue;
            a[tot].from=s[i];
            a[tot].to=s[j];
            a[tot].len=l;
            ++tot;
        }
        Kruskal();
        if(cnt!=n-1) cout<<"oh!"<<endl;
        else printf("%.1lf\n",ans*100);

    }
}



猜你喜欢

转载自blog.csdn.net/codetypeman/article/details/80400534