HDU - 5131 Song Jiang's rank list

Song Jiang's rank list

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)
Total Submission(s): 2232    Accepted Submission(s): 1231


Problem Description
《Shui Hu Zhuan》,also 《Water Margin》was written by Shi Nai'an -- an writer of Yuan and Ming dynasty. 《Shui Hu Zhuan》is one of the Four Great Classical Novels of Chinese literature. It tells a story about 108 outlaws. They came from different backgrounds (including scholars, fishermen, imperial drill instructors etc.), and all of them eventually came to occupy Mout Liang(or Liangshan Marsh) and elected Song Jiang as their leader.

In order to encourage his military officers, Song Jiang always made a rank list after every battle. In the rank list, all 108 outlaws were ranked by the number of enemies he/she killed in the battle. The more enemies one killed, one's rank is higher. If two outlaws killed the same number of enemies, the one whose name is smaller in alphabet order had higher rank. Now please help Song Jiang to make the rank list and answer some queries based on the rank list.
 

Input
There are no more than 20 test cases.

For each test case:

The first line is an integer N (0<N<200), indicating that there are N outlaws.

Then N lines follow. Each line contains a string S and an integer K(0<K<300), meaning an outlaw's name and the number of enemies he/she had killed. A name consists only letters, and its length is between 1 and 50(inclusive). Every name is unique. 

The next line is an integer M (0<M<200) ,indicating that there are M queries.

Then M queries follow. Each query is a line containing an outlaw's name. 
The input ends with n = 0
 

Output
For each test case, print the rank list first. For this part in the output ,each line contains an outlaw's name and the number of enemies he killed. 

Then, for each name in the query of the input, print the outlaw's rank. Each outlaw had a major rank and a minor rank. One's major rank is one plus the number of outlaws who killed more enemies than him/her did.One's minor rank is one plus the number of outlaws who killed the same number of enemies as he/she did but whose name is smaller in alphabet order than his/hers. For each query, if the minor rank is 1, then print the major rank only. Or else Print the major rank, blank , and then the minor rank. It's guaranteed that each query has an answer for it.
 

Sample Input
 
  
5 WuSong 12 LuZhishen 12 SongJiang 13 LuJunyi 1 HuaRong 15 5 WuSong LuJunyi LuZhishen HuaRong SongJiang 0
 

Sample Output
 
  
HuaRong 15 SongJiang 13 LuZhishen 12 WuSong 12 LuJunyi 1 3 2 5 3 1 2
 

Source
 

给出人名和杀敌数,然后按照杀敌数排名,如果杀敌数一样,按照名字字典序排列。然后又n组询问
每一组询问给出一个人名,输出这个人的主要排名和次要排名,如果杀敌数一样那么主要排名就是一样的并
取排名靠前的名次,次要排名是,排名在这个人前边的人有几个和他杀敌数是一样的

#include <iostream>
#include <string>
#include <algorithm>
using namespace std;
struct peo
{
	string name;
	int kill;
	int rank1;
	int rank2;
}a[303];
int cmp(peo a,peo b)
{
	if(a.kill!=b.kill)
	{
		return a.kill>b.kill;
	}else {
		return a.name<b.name;
	}
}
int main()
{
	int n;
	while(cin>>n,n)
	{
		for(int i=0;i<n;i++)
		{
			cin>>a[i].name>>a[i].kill;
		}
		sort(a,a+n,cmp);	
		for(int i=0;i<n;i++)
		{
			cout<<a[i].name<<" "<<a[i].kill<<endl; 
		}
		for(int i=0;i<n;i++)
		{
			//cout<<a[i].name<<" "<<a[i].kill<<endl;
			a[i].rank1=i+1;//paiming
			a[i].rank2=0;//副排名 
		}
		int m;
		cin>>m;
		while(m--)
		{
			string name1;
			cin>>name1;
			int now_rank;//记录现有名次 
			for(int i=0;i<n;i++)
			{
				if(a[i].name==name1)
				{
					now_rank=a[i].rank1;
					break; 
				} 
			}
			for(int i=0;i<now_rank-1;i++)
			{
				if(a[i].kill==a[now_rank-1].kill)
				{
				//	cout<<a[i].name<<"*"<<endl;
					a[now_rank-1].rank2++;
				}
			}
			for(int i=0;i<now_rank-1;i++)
			{
				if(a[i].kill==a[now_rank-1].kill)
				{
				//	cout<<a[i].name<<"*"<<endl;
					a[now_rank-1].rank1=a[i].rank1;
					break;
				}
			}
			if(a[now_rank-1].rank2>0)
			{
				cout<<a[now_rank-1].rank1<<" "<<a[now_rank-1].rank2+1<<endl;
				
			}else cout<<a[now_rank-1].rank1<<endl;
		}
	}return 0;
}
数据有点水 写的有点麻烦、

猜你喜欢

转载自blog.csdn.net/qq_40046426/article/details/80994467
今日推荐