HDU 1213 最大连续子序列

给定K个整数的序列{ N1, N2, ..., NK },其任意连续子序列可表示为{ Ni, Ni+1, ...,
Nj },其中 1 <= i <= j <= K。最大连续子序列是所有连续子序列中元素和最大的一个, 
例如给定序列{ -2, 11, -4, 13, -5, -2 },其最大连续子序列为{ 11, -4, 13 },最大和 
为20。 
在今年的数据结构考卷中,要求编写程序得到最大和,现在增加一个要求,即还需要输出该 
子序列的第一个和最后一个元素。 
Input测试输入包含若干测试用例,每个测试用例占2行,第1行给出正整数K( < 10000 ),第2行给出K个整数,中间用空格分隔。当K为0时,输入结束,该用例不被处理。 
Output对每个测试用例,在1行里输出最大和、最大连续子序列的第一个和最后一个元 
素,中间用空格分隔。如果最大连续子序列不唯一,则输出序号i和j最小的那个(如输入样例的第2、3组)。若所有K个元素都是负数,则定义其最大和为0,输出整个序列的首尾元素。 
Sample Input
6
-2 11 -4 13 -5 -2
10
-10 1 2 3 4 -5 -23 3 7 -21
6
5 -8 3 2 5 0
1
10
3
-1 -5 -2
3
-1 0 -2
0
Sample Output
20 11 13
10 1 4
10 3 5
10 10 10
0 -1 -2
0 0 0


        
  

Huge input, scanf is recommended.

#include<iostream>
#include<algorithm>
#include<stdio.h>
int a[10005];
using namespace std;
int main()
{
             int n;
             while(scanf("%d",&n)&&n)
             {
                             int xi=0,xj=0;
                             int num=0;
                             for(int i=0;i<n;i++)
                             {
                                             cin>>a[i];
                                             if(a[i]<0)num++;
                             }
                             if(num==n)cout<<0<<" "<<a[0]<<" "<<a[n-1]<<endl;
                             else {
                             int sum=0;
                             int max=-99999;
                             for(int i=0,j=0;i<n;i++)
                             {
                                            sum+=a[i];
                                            if(sum>max){max=sum;xj=i;xi=j;}
                                            if(sum<0){sum=0;j=i+1;}
                             }
                             cout<<max<<" "<<a[xi]<<" "<<a[xj]<<endl;
                             }
             }
             return 0;

}


猜你喜欢

转载自blog.csdn.net/nihaopeng521/article/details/76175731