Emergency(变形弗洛伊德 Floyd)

题目:

 Emergency


题目描述

Kudo’s real name is not Kudo. Her name is Kudryavka Anatolyevna Strugatskia, and Kudo is only her nickname.

Now, she is facing an emergency in her hometown:

Her mother is developing a new kind of spacecraft. This plan costs enormous energy but finally failed. What’s more, because of the failed project, the government doesn’t have enough resource take measure to the rising sea levels caused by global warming, lead to an island flooded by the sea.

Dissatisfied with her mother’s spacecraft and the government, civil war has broken out. The foe wants to arrest the spacecraft project’s participants and the “Chief criminal” – Kudo’s mother – Doctor T’s family.

At the beginning of the war, all the cities are occupied by the foe. But as time goes by, the cities recaptured one by one.

To prevent from the foe’s arrest and boost morale, Kudo and some other people have to distract from a city to another. Although they can use some other means to transport, the most convenient way is using the inter-city roads. Assuming the city as a node and an inter-city road as an edge, you can treat the map as a weighted directed multigraph. An inter-city road is available if both its endpoint is recaptured.

Here comes the problem.

Given the traffic map, and the recaptured situation, can you tell Kudo what’s the shortest path from one city to another only passing the recaptured cities?

输入

The input consists of several test cases.

The first line of input in each test case contains three integers N (0<N300), M (0<M100000)

 and Q (0<Q100000), which represents the number of cities, the numbers of inter-city roads and the number of operations.

Each of the next M lines contains three integer x, y and z, represents there is an inter-city road starts from x, end up with y and the length is z. You can assume that 0<z10000.

Each of the next Q lines contains the operations with the following format:

a) x – means city x has just been recaptured.

b) x y – means asking the shortest path from x to y only passing the recaptured cities.

The last case is followed by a line containing three zeros.

输出

For each case, print the case number (1, 2 …) first.

For each operation 0, if city x is already recaptured (that is,the same 0 x operation appears again), print “City x is already recaptured.”

For each operation 1, if city x or y is not recaptured yet, print “City x or y is not available.” otherwise if Kudo can go from city x to city y only passing the recaptured cities, print the shortest path’s length; otherwise print “No such path.”

Your output format should imitate the sample output. Print a blank line after each test case.

样例输入

3 3 6
0 1 1
1 2 1
0 2 3
1 0 2
0 0
0 2
1 0 2
1 2 0
0 2

0 0 0

样例输出

Case 1:
City 0 or 2 is not available.
3
No such path.
City 2 is already recaptured.


题目描述:

有n个点,m条路,单向路,0代表加入某一个城市,1代表求从x点到y点的最小路径,此时的路径必须是通过占领的城市,4种输出,没有占领那个城市,已经占领那个城市求出最短路径,求不出最短路径,重复占领。

每加入一个点,如果之前没有加入,就用这个点松弛每条边(弗洛伊德),每个弗洛伊德只需两重for循环,初始时,所有的城市都没有被占领,每加入一座城市,就松弛即可。

代码:

#include<cstdio>
#include<cstring>
const int INF=99999999;
int n,m,q;
int e[500][500],book[500];
void floyd(int x){
    int i,j;
    for(i=0;i<n;i++){
        for(j=0;j<n;j++){
            if(e[i][j] > e[i][x] + e[x][j]){
                e[i][j] = e[i][x] + e[x][j];
            }
        }
    }
    /*for(i=0;i<n;i++){
        for(j=0;j<n;j++){
            printf("%9d",e[i][j]);
        }
        printf("\n");
    }*/
}
int main()
{
    int u,v,w,op,x,y,i,j,t=1;
    while(scanf("%d%d%d",&n,&m,&q) == 3 && n+m+q != 0){
        printf("Case %d:\n",t++);
         
        for(i=0;i<n;i++){
            for(j=0;j<n;j++){
                e[i][j] =  i==j?0:INF;
            }
        }
         
        while(m--){
            scanf("%d%d%d",&u,&v,&w);
            if(e[u][v] > w)
                e[u][v] = w;
        }
        /*for(i=0;i<n;i++){
            for(j=0;j<n;j++){
                printf("%9d",e[i][j]);
            }
            printf("\n");
        }*/
        memset(book,0,sizeof(book));
        while(q--){
            scanf("%d",&op);
            if(op == 0){
                scanf("%d",&x);
                if(book[x])
                    printf("City %d is already recaptured.\n",x);
                else{
                    floyd(x);
                    book[x]=1;
                }
            }
            else
            {
                scanf("%d%d",&x,&y);
                if(book[x] == 0 || book[y] == 0){
                    printf("City %d or %d is not available.\n",x,y);
                    continue;
                }
                if(e[x][y] < INF)
                    printf("%d\n",e[x][y]);
                else
                    printf("No such path.\n");
            }
        }
        printf("\n");
    }
    return 0;
}





猜你喜欢

转载自blog.csdn.net/hunt_er/article/details/80245378
今日推荐