HDU 3374 KMP+最小最大表示法

String Problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4274    Accepted Submission(s): 1727


Problem Description
Give you a string with length N, you can generate N strings by left shifts. For example let consider the string “SKYLONG”, we can generate seven strings:
String Rank 
SKYLONG 1
KYLONGS 2
YLONGSK 3
LONGSKY 4
ONGSKYL 5
NGSKYLO 6
GSKYLON 7
and lexicographically first of them is GSKYLON, lexicographically last is YLONGSK, both of them appear only once.
  Your task is easy, calculate the lexicographically fisrt string’s Rank (if there are multiple answers, choose the smallest one), its times, lexicographically last string’s Rank (if there are multiple answers, choose the smallest one), and its times also.
 

Input
  Each line contains one line the string S with length N (N <= 1000000) formed by lower case letters.
 

Output
Output four integers separated by one space, lexicographically fisrt string’s Rank (if there are multiple answers, choose the smallest one), the string’s times in the N generated strings, lexicographically last string’s Rank (if there are multiple answers, choose the smallest one), and its times also.
 

Sample Input
 
  
abcder aaaaaa ababab
 

Sample Output
 
  
1 1 6 1 1 6 1 6 1 3 2 3
 

Author
WhereIsHeroFrom
 

Source
 

Recommend

lcy   |   We have carefully selected several similar problems for you:  3371 3372 3373 3375 3376 


关于这道题 其实次数可以从最小循环节去求 因为你如果是周期串 才会有次数

那么我们现在再看这个问题

最小最大表示法下标好求

次数直接用最小循环节去求 那么得出答案

#include<iostream>
#include<string>
#include<cstring>
#include<cstdio>
#define MAX 1000005
using namespace std;
char p[MAX];
char p1[MAX*2];  //把模式串复制一份
int len,Next[MAX],cnt,len1;

void getnext()
{
     int i = 0,j = -1;
     while(i<len){
        if(j==-1||p[i]==p[j]) {++i,++j,Next[i]=j;}
        else j = Next[j];
     }
     return ;
}

int getmin(char *p)   //最小表示法
{
     int len2 = strlen(p);
     int i=0,j=1,k=0;
     while(i<len2&&j<len2&&k<len2)
     {
          if(p1[i+k]==p1[j+k])
               k++;
          else if(p1[i+k]<p1[j+k])
          {
               j=j+k+1;
               k=0;
          }
          else
          {
               i=i+k+1;
               k=0;
          }
          if(i==j)
              j++;
     }
     return i<j?i:j;
}

int getmax(char *p)   //最大表示法
{
    int len2 = strlen(p);
     int i=0,j=1,k=0;
     while(i<len2&&j<len2&&k<len2)
     {
          if(p1[i+k]==p1[j+k])
               k++;
          else if(p1[i+k]<p1[j+k])
          {
               i=i+k+1;
               k=0;
          }
          else
          {
               j=j+k+1;
               k=0;
          }
          if(i==j)
              j++;
     }
     return i<j?i:j;
}

int main()
{
     while(~scanf("%s",p))
     {
          len=strlen(p);
          strcpy(p1,p);
          strcat(p1,p);
          Next[0] = -1;
          getnext();
          cnt=1; //记录循环的次数,利用最小循环节的知识
          if(len%(len-Next[len])==0)
             cnt=len/(len-Next[len]);
          len1=len/cnt;    //只考虑循环节以前的即可
          printf("%d %d %d %d\n",getmin(p)+1,cnt,getmax(p)+1,cnt);
     }
     return 0;
}


猜你喜欢

转载自blog.csdn.net/heucodesong/article/details/80992006
今日推荐