田忌赛马(贪心)

Tian Ji -- The Horse Racing

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 34248    Accepted Submission(s): 10372


Problem Description
Here is a famous story in Chinese history.

"That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others."

"Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from the loser."

"Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian's. As a result, each time the king takes six hundred silver dollars from Tian."

"Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match."

"It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king's regular, and his super beat the king's plus. What a simple trick. And how do you think of Tian Ji, the high ranked official in China?"



Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian's horses on one side, and the king's horses on the other. Whenever one of Tian's horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching...

However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses --- a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too advanced tool to deal with the problem.

In this problem, you are asked to write a program to solve this special case of matching problem.
 

Input
The input consists of up to 50 test cases. Each case starts with a positive integer n (n <= 1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian’s horses. Then the next n integers on the third line are the speeds of the king’s horses. The input ends with a line that has a single 0 after the last test case.
 

Output
For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.
 

Sample Input
 
  
3 92 83 71 95 87 74 2 20 20 20 20 2 20 19 22 18 0
 

Sample Output
 
  
200 0 0
 1、每次失败的马匹,要体现其失败价值最大化,即必败无疑的马匹要跟其King最好的马匹比赛,才能实现其失败的价值!(即给后继马匹争取更大的赢取几率)
  2、每次胜利的马匹,要体现其胜利价值最大化,即要赢了king里相对最好的马匹!(即也给后继马匹争取更大的赢取几率)
  3、拒绝平局
#include<iostream>
#include<algorithm>
using namespace std;
int tian[1005],king[1005];
int main()
{
	int n,m,i,minn,maxx,s;
	while(cin>>n&&n)
	{
		for(i=0;i<n;i++) cin>>tian[i];
		for(i=0;i<n;i++) cin>>king[i];
		sort(tian,tian+n);
		sort(king,king+n);
		minn=0; maxx=n-1; s=0;
		for(i=0;i<n;)
		{
			if(tian[i]>king[minn]) s++,minn++,i++;
			else if(tian[n-1]>king[maxx]) s++,n--,maxx--;
			else
			{
				if(tian[i]<king[maxx]) s--;
				maxx--;//包含平局的情况
				i++;
			}
		}
		cout<<s*200<<endl;
	}
}

以下内容为转载:
这道蛮有意思贪心题 
做这道题的方法就像上课学的数据结构某些部分类似 就是指针似的移来移去。。。
1.把田鸡和王的最快的马进行比较(对了,记得先从大到小的速度排序),
(1)如果田鸡的最快马快的话那就银币+200,然后田鸡的最快马--,王的最快马也--;
(2)如果是王的最快马比田鸡的最快马快的话,那就保留田鸡的最快马,然后拿田鸡的最慢马和王的最慢马进行比较,同时银币数量-200,然后田鸡最快马不变,最慢马++;王的最快马--。。
2.把田鸡的最慢马和王的最慢马进行比较
(1)田鸡的最慢马比王的快;田最慢马++,王最慢马++;
(2)王的最慢马比田鸡的快;那就拿田鸡的最慢马和王的最快马进行比较;田鸡最慢马++,王最快马--。
3.最快的和最慢的如果都一样,那同样拿田鸡的最慢马和王的最快马进行比较;田鸡最慢马++,王最快马--
#include<stdio.h>  
#include<iostream>  
#include<string.h>  
#include<algorithm>  
const int maxn=1005;  
using namespace std;  
  
int main()  
{  
    int n,i,j,sum;  
    int tian[maxn],king[maxn];  
    while(~scanf("%d",&n)&n)  
    {  
        sum=0;  
        for(i=0; i<n; i++)  
            scanf("%d",&tian[i]);  
        for(i=0; i<n; i++)  
            scanf("%d",&king[i]);  
        sort(tian,tian+n);  
        sort(king,king+n);  
        int t_max,k_max,t_min,k_min;  
        t_max=k_max=n-1;  
        t_min=k_min=0;  
        while(t_min<=t_max&&k_min<=k_max)  
        {  
            if(tian[t_max]>king[k_max])  
            {  
                sum+=200;  
                t_max--;  
                k_max--;  
            }  
            else if(king[k_max]>tian[t_max])  
            {  
                sum-=200;  
                t_min++;  
                k_max--;  
            }  
            else  
            {  
                if(tian[t_min]>king[k_min])  
                {  
                    sum+=200;  
                    t_min++;  
                    k_min++;  
                }  
                else if(tian[t_min]<king[k_min])  
                {  
                    sum-=200;  
                    t_min++;  
                    k_max--;  
                }  
                else  
                {  
                    if(tian[t_min] < king[k_max])  
                        sum-=200;  
                    t_min++;  
                    k_max--;  
                }  
            }  
        }  
        printf("%d\n",sum);  
    }  
    return 0;  
}  



猜你喜欢

转载自blog.csdn.net/luojiushenzi/article/details/80138857