B - Children of the Candy Corn(双dfs+bfs)

The cornfield maze is a popular Halloween treat. Visitors are shown the entrance and must wander through the maze facing zombies, chainsaw-wielding psychopaths, hippies, and other terrors on their quest to find the exit. 

One popular maze-walking strategy guarantees that the visitor will eventually find the exit. Simply choose either the right or left wall, and follow it. Of course, there's no guarantee which strategy (left or right) will be better, and the path taken is seldom the most efficient. (It also doesn't work on mazes with exits that are not on the edge; those types of mazes are not represented in this problem.) 

As the proprieter of a cornfield that is about to be converted into a maze, you'd like to have a computer program that can determine the left and right-hand paths along with the shortest path so that you can figure out which layout has the best chance of confounding visitors.

Input

Input to this problem will begin with a line containing a single integer n indicating the number of mazes. Each maze will consist of one line with a width, w, and height, h (3 <= w, h <= 40), followed by h lines of w characters each that represent the maze layout. Walls are represented by hash marks ('#'), empty space by periods ('.'), the start by an 'S' and the exit by an 'E'. 

Exactly one 'S' and one 'E' will be present in the maze, and they will always be located along one of the maze edges and never in a corner. The maze will be fully enclosed by walls ('#'), with the only openings being the 'S' and 'E'. The 'S' and 'E' will also be separated by at least one wall ('#'). 

You may assume that the maze exit is always reachable from the start point.

Output

For each maze in the input, output on a single line the number of (not necessarily unique) squares that a person would visit (including the 'S' and 'E') for (in order) the left, right, and shortest paths, separated by a single space each. Movement from one square to another is only allowed in the horizontal or vertical direction; movement along the diagonals is not allowed.

Sample Input

2
8 8
########
#......#
#.####.#
#.####.#
#.####.#
#.####.#
#...#..#
#S#E####
9 5
#########
#.#.#.#.#
S.......E
#.#.#.#.#
#########

Sample Output

37 5 5
17 17 9
代码:
#include<cstdio>
#include<iostream>
#include<queue>
#include<cstring>
#include<string>
using namespace std;
char g[50][50];  //迷宫 
bool in[50][50]; //标记 
int w,h;  //迷宫大小(列、行) 
int lef,rig,les; //答案 
bool flag; //标记 
struct point//广搜队列元素 
{
	int x;
	int y;
	int step;
	point(){}
	point(int xx,int yy,int s):x(xx),y(yy),step(s){}
};
point start; //迷宫起点 
point ex;    //迷宫终点 
void init()//初始化 
{
	memset(g,'#',sizeof(g));
	memset(in,0,sizeof(in));
}
bool check(int x,int y) //检查点 
{
	if(flag==0&&g[x][y]!='#')
	return true;
	else
	return false;
}
void dfsl(int x,int y,char to,int step)//左深度优先搜索 
{
	if(!check(x,y))
	return;
	if(ex.x==x&&ex.y==y)
	{
		lef=step;
		flag=1;
		return;
	}
	if(to=='u')//如果朝上走 
	{
		if(check(x,y-1))
		dfsl(x,y-1,'l',step+1);
		if(check(x-1,y))
		dfsl(x-1,y,'u',step+1);
		if(check(x,y+1))
		dfsl(x,y+1,'r',step+1);
		if(check(x+1,y))
		dfsl(x+1,y,'d',step+1);
		return;
	}
	else if(to=='d')
	{
		if(check(x,y+1))
		dfsl(x,y+1,'r',step+1);
		if(check(x+1,y))
		dfsl(x+1,y,'d',step+1);
		if(check(x,y-1))
		dfsl(x,y-1,'l',step+1);
		if(check(x-1,y))
		dfsl(x-1,y,'u',step+1);
		return;
	}
	else if(to=='l')
	{
		if(check(x+1,y))
		dfsl(x+1,y,'d',step+1);
		if(check(x,y-1))
		dfsl(x,y-1,'l',step+1);
		if(check(x-1,y))
		dfsl(x-1,y,'u',step+1);
		if(check(x,y+1))
		dfsl(x,y+1,'r',step+1);
		return;
	}
	else if(to=='r')
	{
		if(check(x-1,y))
		dfsl(x-1,y,'u',step+1);
		if(check(x,y+1))
		dfsl(x,y+1,'r',step+1);
		if(check(x+1,y))
		dfsl(x+1,y,'d',step+1);
		if(check(x,y-1))
		dfsl(x,y-1,'l',step+1);
		return;
	}
}
void dfsr(int x,int y,char to,int step)//右深度优先搜索 
{
	if(!check(x,y))
	return;
	if(ex.x==x&&ex.y==y)
	{
		rig=step;
		flag=1;
		return;
	}
	if(to=='u')
	{
		if(check(x,y+1))
		dfsr(x,y+1,'r',step+1);
		if(check(x-1,y))
		dfsr(x-1,y,'u',step+1);
		if(check(x,y-1))
		dfsr(x,y-1,'l',step+1);
		if(check(x+1,y))
		dfsr(x+1,y,'d',step+1);
		return;
	}
	else if(to=='d')
	{
		if(check(x,y-1))
		dfsr(x,y-1,'l',step+1);
		if(check(x+1,y))
		dfsr(x+1,y,'d',step+1);
		if(check(x,y+1))
		dfsr(x,y+1,'r',step+1);
		if(check(x-1,y))
		dfsr(x-1,y,'u',step+1);
		return;
	}
	else if(to=='l')
	{
		if(check(x-1,y))
		dfsr(x-1,y,'u',step+1);
		if(check(x,y-1))
		dfsr(x,y-1,'l',step+1);
		if(check(x+1,y))
		dfsr(x+1,y,'d',step+1);
		if(check(x,y+1))
		dfsr(x,y+1,'r',step+1);
		return;
	}
	else if(to=='r')
	{
		if(check(x+1,y))
		dfsr(x+1,y,'d',step+1);
		if(check(x,y+1))
		dfsr(x,y+1,'r',step+1);
		if(check(x-1,y))
		dfsr(x-1,y,'u',step+1);
		if(check(x,y-1))
		dfsr(x,y-1,'l',step+1);
		return;
	}
}
void bfs()//广搜 
{
	queue<point> q;
	q.push(start);
	in[start.x][start.y]=1;
	int dx[4]={1,0,-1,0};
	int dy[4]={0,1,0,-1};
	while(q.size())
	{
		point now=q.front();
		if(now.x==ex.x&&now.y==ex.y)
		{
			les=now.step;
			break;
		}
		q.pop();
		for(int i=0;i<4;i++)
		{
			int xx=now.x+dx[i];
			int yy=now.y+dy[i];
			if(!in[xx][yy]&&g[xx][yy]!='#')
			{
				q.push(point(xx,yy,now.step+1));
				in[xx][yy]=1;
			}
		}
	}
} 

int main(void)
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d %d",&w,&h);
		init();
		for(int i=1;i<=h;i++)
		{
			for(int j=1;j<=w;j++)
			{
				scanf(" %c",&g[i][j]);
				if(g[i][j]=='S')
				{
					//g[i][j]='.';
					start.x=i;
					start.y=j;
					start.step=1;
				}
				else if(g[i][j]=='E')
				{
					ex.x=i;
					ex.y=j;
				}
			}
		}
		flag=0;
		dfsl(start.x,start.y,'u',1);
		flag=0;
		dfsr(start.x,start.y,'u',1);
		bfs();
		printf("%d %d %d\n",lef,rig,les);
	}
	return 0;
} 



猜你喜欢

转载自blog.csdn.net/nucleare/article/details/80443852