POJ 1753 B - Flip Game

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules: 

  1. Choose any one of the 16 pieces. 
  2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).


Consider the following position as an example: 

bwbw 
wwww 
bbwb 
bwwb 
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become: 

bwbw 
bwww 
wwwb 
wwwb 
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal. 

Input

The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.

Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible" (without quotes).

Sample Input

bwwb
bbwb
bwwb
bwww

Sample Output

4

题意:给你一个4*4的图,每个方格里要么是白色要么是黑色,当把一个格子里的颜色给改变另一种颜色,那这个格子周围的格子也都改变颜色,问最少改变几次能让整个图为同一颜色。

分析:我的思路是从第一个格子开始搜,要么选择改变颜色,要么选择不改变,直接搜下一个格子,在每次搜格子之前需要判断图是否为纯色,如果符合条件则维持一个最小值,最后输出最小值。

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define INF 0x3f3f3f3f
char s[10];
int map[10][10];
int cout;
int check()         //判断图像是否纯色
{
    int x=map[0][0];
    for(int i=0;i<4;i++)
        for(int j=0;j<4;j++)
    {
        if(map[i][j]!=x) 
            return 0;
    }
    return 1;
}
void fun(int x,int y)           //格子反转
{
    map[x][y]=!map[x][y];
    if(x-1>=0)
        map[x-1][y]=!map[x-1][y];
    if(x+1<4)
        map[x+1][y]=!map[x+1][y];
    if(y-1>=0)
        map[x][y-1]=!map[x][y-1];
    if(y+1<4)
        map[x][y+1]=!map[x][y+1];
}
int dfs(int x,int y,int t)
{
    if(check())        //图像为纯色
    {
        if(cout>t)     //维持一个最小值
        {
            cout=t;
            return 0;
        }
    }
    if(x>=4||y>=4)
        return 0;
    int dx=(x+1)%4;     //将坐标更新为下一个点
    int dy=y+(x+1)/4;
    dfs(dx,dy,t);       //不在此格子上反转
    fun(x,y);
    dfs(dx,dy,t+1);     //在此格子上进行反转
    fun(x,y);
    return 0;
}
int main()
{
    for(int i=0;i<4;i++)  //读入图像
    {
        scanf("%s",s);
        for(int j=0;j<4;j++)
        {
            if(s[j]=='b')   //将字符转换为数字
                map[i][j]=0;
            else
                map[i][j]=1;
        }
    }
    cout=INF;              
    dfs(0,0,0);
    if(cout==INF)            //没有符合条件的
        printf("Impossible\n");
    else
        printf("%d\n",cout);
}

猜你喜欢

转载自blog.csdn.net/Vace___yun/article/details/81210398