HDU3410Passing the Message(单调栈)

Passing the Message

Problem Description
What a sunny day! Let’s go picnic and have barbecue! Today, all kids in “Sun Flower” kindergarten are prepared to have an excursion. Before kicking off, teacher Liu tells them to stand in a row. Teacher Liu has an important message to announce, but she doesn’t want to tell them directly. She just wants the message to spread among the kids by one telling another. As you know, kids may not retell the message exactly the same as what they was told, so teacher Liu wants to see how many versions of message will come out at last. With the result, she can evaluate the communication skills of those kids.
Because all kids have different height, Teacher Liu set some message passing rules as below:

1.She tells the message to the tallest kid.

2.Every kid who gets the message must retell the message to his “left messenger” and “right messenger”.

3.A kid’s “left messenger” is the kid’s tallest “left follower”.

4.A kid’s “left follower” is another kid who is on his left, shorter than him, and can be seen by him. Of course, a kid may have more than one “left follower”.

5.When a kid looks left, he can only see as far as the nearest kid who is taller than him.

The definition of “right messenger” is similar to the definition of “left messenger” except all words “left” should be replaced by words “right”.

For example, suppose the height of all kids in the row is 4, 1, 6, 3, 5, 2 (in left to right order). In this situation , teacher Liu tells the message to the 3rd kid, then the 3rd kid passes the message to the 1st kid who is his “left messenger” and the 5th kid who is his “right messenger”, and then the 1st kid tells the 2nd kid as well as the 5th kid tells the 4th kid and the 6th kid.
Your task is just to figure out the message passing route.
 

Input
The first line contains an integer T indicating the number of test cases, and then T test cases follows.
Each test case consists of two lines. The first line is an integer N (0< N <= 50000) which represents the number of kids. The second line lists the height of all kids, in left to right order. It is guaranteed that every kid’s height is unique and less than 2^31 – 1 .
 

Output
For each test case, print “Case t:” at first ( t is the case No. starting from 1 ). Then print N lines. The ith line contains two integers which indicate the position of the ith (i starts form 1 ) kid’s “left messenger” and “right messenger”. If a kid has no “left messenger” or “right messenger”, print ‘0’ instead. (The position of the leftmost kid is 1, and the position of the rightmost kid is N)
 

Sample Input
 
  
2 5 5 2 4 3 1 5 2 1 4 3 5
 

Sample Output
 
  
Case 1: 0 3 0 0 2 4 0 5 0 0 Case 2: 0 2 0 0 1 4 0 0 3 0

题意:求每个数左边和右边比他矮的当中最高的是那个(位置).

思路:维护一个递减单调栈即可.

代码:

#include<bits/stdc++.h>
#define mem(a,b) memset(a,b,sizeof(a))
#define mod 1000000007
using namespace std;
typedef long long ll;
const int maxn = 1e5+5;
const double esp = 1e-12;
const int ff = 0x3f3f3f3f;
map<int,int>::iterator it;

int n;
int a[maxn],l[maxn],r[maxn];

int main()
{
	int t,cas = 0;
	cin>>t;
	
	while(t--)
	{
		mem(l,0);
		mem(r,0);
		scanf("%d",&n);
		for(int i = 1;i<= n;i++)
			scanf("%d",&a[i]);
		
		stack<int> q;
		
		for(int i = 1;i<= n;i++)
		{
			while(!q.empty()&&a[q.top()]< a[i])
				l[i] = q.top(),q.pop();
			q.push(i);
		}
		
		while(!q.empty()) q.pop();
		for(int i = n;i>= 1;i--)
		{
			while(!q.empty()&&a[q.top()]< a[i])
				r[i] = q.top(),q.pop();
			q.push(i);
		}
		
		printf("Case %d:\n",++cas);
		
		for(int i = 1;i<= n;i++)
			printf("%d %d\n",l[i],r[i]);
	}
	
	return 0;
}

猜你喜欢

转载自blog.csdn.net/nka_kun/article/details/80152795