Passing the Message(单调栈)

Passing the Message

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1086    Accepted Submission(s): 709


 

Problem Description

What a sunny day! Let’s go picnic and have barbecue! Today, all kids in “Sun Flower” kindergarten are prepared to have an excursion. Before kicking off, teacher Liu tells them to stand in a row. Teacher Liu has an important message to announce, but she doesn’t want to tell them directly. She just wants the message to spread among the kids by one telling another. As you know, kids may not retell the message exactly the same as what they was told, so teacher Liu wants to see how many versions of message will come out at last. With the result, she can evaluate the communication skills of those kids.
Because all kids have different height, Teacher Liu set some message passing rules as below:

1.She tells the message to the tallest kid.

2.Every kid who gets the message must retell the message to his “left messenger” and “right messenger”.

3.A kid’s “left messenger” is the kid’s tallest “left follower”.

4.A kid’s “left follower” is another kid who is on his left, shorter than him, and can be seen by him. Of course, a kid may have more than one “left follower”.

5.When a kid looks left, he can only see as far as the nearest kid who is taller than him.

The definition of “right messenger” is similar to the definition of “left messenger” except all words “left” should be replaced by words “right”.

For example, suppose the height of all kids in the row is 4, 1, 6, 3, 5, 2 (in left to right order). In this situation , teacher Liu tells the message to the 3rd kid, then the 3rd kid passes the message to the 1st kid who is his “left messenger” and the 5th kid who is his “right messenger”, and then the 1st kid tells the 2nd kid as well as the 5th kid tells the 4th kid and the 6th kid.
Your task is just to figure out the message passing route.

Input

The first line contains an integer T indicating the number of test cases, and then T test cases follows.
Each test case consists of two lines. The first line is an integer N (0< N <= 50000) which represents the number of kids. The second line lists the height of all kids, in left to right order. It is guaranteed that every kid’s height is unique and less than 2^31 – 1 .

Output

For each test case, print “Case t:” at first ( t is the case No. starting from 1 ). Then print N lines. The ith line contains two integers which indicate the position of the ith (i starts form 1 ) kid’s “left messenger” and “right messenger”. If a kid has no “left messenger” or “right messenger”, print ‘0’ instead. (The position of the leftmost kid is 1, and the position of the rightmost kid is N)

Sample Input

 

2 5 5 2 4 3 1 5 2 1 4 3 5

Sample Output

 

Case 1: 0 3 0 0 2 4 0 5 0 0 Case 2: 0 2 0 0 1 4 0 0 3 0

Source

2010 National Programming Invitational Contest Host by ZSTU

Recommend

wxl   |   We have carefully selected several similar problems for you:  3405 3406 3407 3408 3411 

题意:发糖给最高的那一个。然后最高的再往两边发,比他矮的离他最近的,最高的那一个(就是他能看到的最高的,不能有人挡)

单调栈好用欸。以前没怎么用过。

维护一个递减序列。

代码:

#include<bits/stdc++.h>
using namespace std;
typedef long long LL;
const int maxn=500000;
int a[maxn],L[maxn],R[maxn];
int main()
{
    int t,n,cas=0;
    scanf("%d",&t);
    while(t--){
        memset(L,0,sizeof(L));
        memset(R,0,sizeof(R));
        ++cas;
        scanf("%d",&n);
        for(int i=1;i<=n;i++){
            scanf("%d",&a[i]);
        }
        stack<int>S;
        for(int i=1;i<=n;i++){
            while(!S.empty() && a[S.top()]<a[i])
                L[i]=S.top(),S.pop();
            S.push(i);
        }
        stack<int>SS;
        for(int i=n;i>=1;i--){
            while(!S.empty() && a[S.top()]<a[i])
                R[i]=S.top(),S.pop();
            S.push(i);
        }
        cout<<"Case "<<cas<<":"<<endl;
        for(int i=1;i<=n;i++){
            cout<<L[i]<<" "<<R[i]<<endl;
        }

    }
    return 0;
}
发布了565 篇原创文章 · 获赞 110 · 访问量 11万+

猜你喜欢

转载自blog.csdn.net/xianpingping/article/details/86929979