poj3045Cow Acrobats_贪心&二分

Cow Acrobats
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 6317   Accepted: 2368

Description

Farmer John's N (1 <= N <= 50,000) cows (numbered 1..N) are planning to run away and join the circus. Their hoofed feet prevent them from tightrope walking and swinging from the trapeze (and their last attempt at firing a cow out of a cannon met with a dismal failure). Thus, they have decided to practice performing acrobatic stunts. 

The cows aren't terribly creative and have only come up with one acrobatic stunt: standing on top of each other to form a vertical stack of some height. The cows are trying to figure out the order in which they should arrange themselves ithin this stack. 

Each of the N cows has an associated weight (1 <= W_i <= 10,000) and strength (1 <= S_i <= 1,000,000,000). The risk of a cow collapsing is equal to the combined weight of all cows on top of her (not including her own weight, of course) minus her strength (so that a stronger cow has a lower risk). Your task is to determine an ordering of the cows that minimizes the greatest risk of collapse for any of the cows.

Input

* Line 1: A single line with the integer N. 

* Lines 2..N+1: Line i+1 describes cow i with two space-separated integers, W_i and S_i. 

Output

* Line 1: A single integer, giving the largest risk of all the cows in any optimal ordering that minimizes the risk.

Sample Input

3
10 3
2 5
3 3

Sample Output

2

Hint

OUTPUT DETAILS: 

Put the cow with weight 10 on the bottom. She will carry the other two cows, so the risk of her collapsing is 2+3-3=2. The other cows have lower risk of collapsing.

Source

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cmath>
#define INF 0x3f3f3f
using namespace std;
const int MAXN=50010;
int N;
struct node{
    int w,s;
}tt[MAXN];
bool cmp(node a,node b)
{
    return a.w+a.s>b.w+b.s;
}
int main()
{
    cin>>N;
        int  sum=0;
       for(int i=0;i<N;i++)
       {
           scanf("%d%d",&tt[i].w,&tt[i].s);
           sum+=tt[i].w;
           //t[i]=(w[i]+s[i])
       }
       sort(tt,tt+N,cmp);
       int ans=-INF;
       for(int i=0;i<N;i++)
       {
           sum-=tt[i].w;
           ans=max(ans,sum-tt[i].s);
       }
       cout<<ans<<endl;

    return 0;
}

  

猜你喜欢

转载自www.cnblogs.com/passion-sky/p/9009060.html