Cow Acrobats POJ - 3045

Farmer John's N (1 <= N <= 50,000) cows (numbered 1..N) are planning to run away and join the circus. Their hoofed feet prevent them from tightrope walking and swinging from the trapeze (and their last attempt at firing a cow out of a cannon met with a dismal failure). Thus, they have decided to practice performing acrobatic stunts. 

The cows aren't terribly creative and have only come up with one acrobatic stunt: standing on top of each other to form a vertical stack of some height. The cows are trying to figure out the order in which they should arrange themselves ithin this stack. 

Each of the N cows has an associated weight (1 <= W_i <= 10,000) and strength (1 <= S_i <= 1,000,000,000). The risk of a cow collapsing is equal to the combined weight of all cows on top of her (not including her own weight, of course) minus her strength (so that a stronger cow has a lower risk). Your task is to determine an ordering of the cows that minimizes the greatest risk of collapse for any of the cows.
Input
* Line 1: A single line with the integer N. 

* Lines 2..N+1: Line i+1 describes cow i with two space-separated integers, W_i and S_i. 
Output
* Line 1: A single integer, giving the largest risk of all the cows in any optimal ordering that minimizes the risk.
Sample Input
3
10 3
2 5
3 3
Sample Output
2
Hint
OUTPUT DETAILS: 

Put the cow with weight 10 on the bottom. She will carry the other two cows, so the risk of her collapsing is 2+3-3=2. The other cows have lower risk of collapsing.



就是个贪心的题目,重量和力量越大的牛放在最下面,所以一遍扫描就行了。

每次取最大值就可以了,但是一开始不能赋值为0,因为忍受程度有可能为赋值。

#include <bits/stdc++.h>
using namespace std;
const int MAX = 5e4+10,INF=0x7fffffff;
struct node{
    int w,s;
}p[MAX];
int n;
bool cmp(node const &a,node const &b){
    return a.w+a.s < b.w+b.s; //从大到小排序,重量大,力气大的当然在下面。
}

int main() {
    scanf("%d",&n);
    for (int i = 0; i < n; i++){
        scanf("%d%d",&p[i].w,&p[i].s);
    }
    sort(p,p+n,cmp);
    long long sum = -INF; //sum的值不能一开始就赋值为0,因为有可能是负值。
    long long tot = 0;
    for (int i = 0; i < n; i++){
        sum = max(sum,tot - p[i].s);
        tot += p[i].w;
    }
    printf("%d\n",sum);
}


猜你喜欢

转载自blog.csdn.net/kidsummer/article/details/80262110