Avatar

Description

In the planet Pandora, Jake found an old encryption algorithm. The plaintext, key and ciphertext are all four decimal numbers and all greater than 0. The way to get the ciphertext from the plaintext and the key is very simple: the ciphertext is the last four digits of the product of the plaintext and the key (for example: the plaintext is 2010 and the key is 4024, and then the product is 8088240. So the ciphertext is 8240).

Note that the plaintext and the key don’t have leading 0, while the ciphertext might have. Now given the plaintext and the key, you are asked to figure out the ciphertext for Jake quickly.

Input

The first line is an integer T, which presents the number of test cases. Then there are T lines, each line has two integers, the first integer is the plaintext and the second is the key.

Output

For each test case, output the ciphertext.

Sample Input

2
2010 4024
1234 1111

Sample Output

8240
0974
#include<stdio.h>  
 
int main()
{  
    int T;  
    scanf("%d",&T);  
    while(T--)
	{  
        int a,b,c;  
        scanf("%d%d",&a,&b);  
        c=a*b;  
        c=c%10000;  
        printf("%00004d\n",c); 
    }  
    return 0;  
}  

/**********************************************************************
	Problem: 1018
	User: song_hai_lei
	Language: C++
	Result: AC
	Time:0 ms
	Memory:1120 kb
**********************************************************************/



猜你喜欢

转载自blog.csdn.net/song_hai_lei/article/details/80444704
今日推荐