POJ2387 - Til the Cows Come Home(Dijkstra 单源最短路)

Til the Cows Come Home (POJ2387)
    Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible. 
    Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it. 
    Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

input

    * Line 1: Two integers: T and N 

    * Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.

output

* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

sample input

5 5
1 2 20
2 3 30
3 4 20
4 5 20

1 5 100

sample output

90

题意:有N个点,给出从a点到b点的距离,当然a和b是互相可以抵达的,问从1到n的最短距离

思路:最短路径问题,一开始用Floyd算法做,超时,改用Dijkstra算法,去重边;

Floyd(超时)

#include <iostream>
#include <algorithm>
#define inf 0x3f3f3f;
using namespace std;
int a[1005][1005];
int main()
{
    std::ios::sync_with_stdio(0);
    int n, m, i, j, k, x;
    while(cin >> m >> n)
    {
        for(i = 1; i <= n; i++)
        {
            for(j = 1; j <= n; j++)
            {
                if(i != j)a[i][j] = inf;
                if(i == j)a[i][j] = 0;
            }
        }
        for(k = 1; k <= m; k++)
        {
            cin >> i >> j >> x;
            if(a[i][j] > x)
            {
                a[i][j] = x;
                a[j][i] = x;
            }
        }
        for(k = 1; k <= n; k++)
        {
            for(i = 1; i <= n; i++)
            {
                for(j = 1; j <= n; j++)
                {
                    if(a[i][j] > a[i][k] + a[k][j])
                    {
                        a[i][j] = a[i][k] + a[k][j];
                    }
                }
            }
        }
        cout << a[1][n] << endl;
    }
    return 0;
}

Dijkstra(AC)

#include <iostream>
#include <algorithm>
using namespace std;
#define inf 0x3f3f3f
int a[1005][1005] = {0}, book[1005] = {0}, vis[1005];
int main()
{
    std::ios::sync_with_stdio(0);
    int n, i, j, k, m, x;
    cin >> m >> n;
    for(i = 1; i <= n; i++)
    {
        for(j = 1; j <= n; j++)
        {
            if(i != j)a[i][j] = inf;
        }
    }
    for(k = 1; k <= m; k++)
    {
        cin >> i >> j >> x;
        if(a[i][j] > x)
        {
            a[i][j] = x;
            a[j][i] = x;
        }
    }
    for(i = 1; i <= n; i++)vis[i] = a[1][i];
    book[1] = 1;
    for(i = 1; i <= n - 1; i++)
    {
        int u = inf, minn;
        for(j = 1; j <= n; j++)
        {
            if(book[j] == 0 && vis[j] < u){u = vis[j]; minn = j;}
        }
        book[minn] = 1;
        for(j = 1; j <= n; j++)
        {
            if(vis[j] > vis[minn] + a[minn][j])
            {
                vis[j] = vis[minn] + a[minn][j];
            }
        }
    }
    cout << vis[n] << endl;
    return 0;
}


猜你喜欢

转载自blog.csdn.net/qq_16530503/article/details/80459091
今日推荐