FZUProblem 2266 Card Game (Third Edition)

Problem 2266 Card Game (Third Edition)

Accept: 179    Submit: 302
Time Limit: 1000 mSec    Memory Limit : 32768 KB

Problem Description

Fat brother and Maze are playing a kind of special (hentai) game with some cards. In this game, every player gets N cards at first and these are their own card decks. Each of these two decks of cards is stacking together at the beginning of the game, and their order would not change during this game. The game goes for N rounds and in each round, Fat Brother and Maze would draw one card from the top of their own remaining card deck and sum these two integers together. If this number is greater than 10, Fat Brother would score 1 victory point and otherwise Maze would score 1 victory points. And then these two cards are removed from the game such that they would not appear in the later rounds. As we all know, Fat Brother is very clever, so he would like to know the number of the victory points he could get if he knows all the integers written in these cards. At the beginning of this game, each player has 0 victory point.

Input

The first line of the date is an integer T (1 <= T <= 100), which is the number of the text cases.

Then T cases follow, each case contains an integer N (1 <= N <= 10000) which described before. Then follow two lines with N integers each. The first N integers indicate the cards which Fat Brother gets from top to bottom, and the second N integers indicate the cards which Maze gets from top to bottom.

All the integers are positive and least than 10.

Output

For each case, output the case number first, and then output the number of victory points Fat Brother would gets in this game.

Sample Input

215623 43 4

Sample Output

Case 1: 1Case 2: 0

水题,能看懂题就好做了。

#include<cstdio>
int t,n;
int a[10000+5];
int b[10000+5];
int main()
{
	int j=1;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		for(int i=0;i<n;i++)	scanf("%d",&a[i]);
		for(int i=0;i<n;i++)	scanf("%d",&b[i]);
		int sum=0;
		for(int i=0;i<n;i++)
		if(a[i]+b[i]>10)	sum++;
		printf("Case %d: %d\n",j++,sum);
	}
	return 0;
}








猜你喜欢

转载自blog.csdn.net/hpuer_random/article/details/80049005