FZU - 2266 Card Game (Third Edition)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/wangke1998/article/details/80057084

Fat brother and Maze are playing a kind of special (hentai) game with some cards. In this game, every player gets N cards at first and these are their own card decks. Each of these two decks of cards is stacking together at the beginning of the game, and their order would not change during this game. The game goes for N rounds and in each round, Fat Brother and Maze would draw one card from the top of their own remaining card deck and sum these two integers together. If this number is greater than 10, Fat Brother would score 1 victory point and otherwise Maze would score 1 victory points. And then these two cards are removed from the game such that they would not appear in the later rounds. As we all know, Fat Brother is very clever, so he would like to know the number of the victory points he could get if he knows all the integers written in these cards. At the beginning of this game, each player has 0 victory point.

Input

The first line of the date is an integer T (1 <= T <= 100), which is the number of the text cases.

Then T cases follow, each case contains an integer N (1 <= N <= 10000) which described before. Then follow two lines with N integers each. The first N integers indicate the cards which Fat Brother gets from top to bottom, and the second N integers indicate the cards which Maze gets from top to bottom.

All the integers are positive and least than 10.

Output

For each case, output the case number first, and then output the number of victory points Fat Brother would gets in this game.

Sample Input
2
1
5
6
2
3 4
3 4
Sample Output
Case 1: 1
Case 2: 0
PS:超简单的水题,就是队长写的时候输入用cin,一直tle,后来想起scanf比cin的用时少,改了一下就过了。

AC:

#include<stdio.h>

int main()
{
int n,i,cnt,j,t;
int a[10005],b[10005];
scanf("%d",&t);
j=1;
while(t--)
{
cnt=0;
scanf("%d",&n);
for(i=0;i<n;i++)
 scanf("%d",&a[i]);
for(i=0;i<n;i++)
{
scanf("%d",&b[i]);
if(a[i]+b[i]>10)
 cnt++;
}
printf("Case %d: %d\n",j++,cnt);
}
return 0;
 } 

猜你喜欢

转载自blog.csdn.net/wangke1998/article/details/80057084