PAT - 乙级 1030 完美数列

1030. 完美数列(25)

时间限制
300 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard
作者
CAO, Peng

给定一个正整数数列,和正整数p,设这个数列中的最大值是M,最小值是m,如果M <= m * p,则称这个数列是完美数列。

现在给定参数p和一些正整数,请你从中选择尽可能多的数构成一个完美数列。

输入格式:

输入第一行给出两个正整数N和p,其中N(<= 105)是输入的正整数的个数,p(<= 109)是给定的参数。第二行给出N个正整数,每个数不超过109

输出格式:

在一行中输出最多可以选择多少个数可以用它们组成一个完美数列。

输入样例:
10 8
2 3 20 4 5 1 6 7 8 9
输出样例:
8
思路: 直接从小到大排列 然后从开始计算
#include<cstdio>
#include<algorithm> 
#define inf 0x3f3f3f3f
using namespace std;

int main(){
	double arr[100005];
	int n;
	double p;
//	cin >> n >> p;
    scanf("%d %lf", &n, &p);
	for(int i = 0; i < n; i++) scanf("%lf", &arr[i]);
	sort(arr, arr + n);
	double max = -1, min = inf, cnt = 0;
	for(int i = 0; i < n; i++){
		for(int j = i + cnt; j < n; j++){
			if(arr[j] > arr[i] * p) break;//否则跳出 从下一个数字的第cnt个开始算 若这个数也符合 则++ 否则继续
			else cnt++;                  //遇到最小值 * p 大于当前数字就+1 
		}
	}
	printf("%.0f", cnt);
	return 0;
}

猜你喜欢

转载自blog.csdn.net/yf224/article/details/80058296
今日推荐