HDU 1301Jungle Roads(最小生成树 prim,输入比较特殊)

题目链接:

http://acm.hdu.edu.cn/showproblem.php?pid=1301

Jungle Roads

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9444    Accepted Submission(s): 6924


Problem Description

The Head Elder of the tropical island of Lagrishan has a problem. A burst of foreign aid money was spent on extra roads between villages some years ago. But the jungle overtakes roads relentlessly, so the large road network is too expensive to maintain. The Council of Elders must choose to stop maintaining some roads. The map above on the left shows all the roads in use now and the cost in aacms per month to maintain them. Of course there needs to be some way to get between all the villages on maintained roads, even if the route is not as short as before. The Chief Elder would like to tell the Council of Elders what would be the smallest amount they could spend in aacms per month to maintain roads that would connect all the villages. The villages are labeled A through I in the maps above. The map on the right shows the roads that could be maintained most cheaply, for 216 aacms per month. Your task is to write a program that will solve such problems.

The input consists of one to 100 data sets, followed by a final line containing only 0. Each data set starts with a line containing only a number n, which is the number of villages, 1 < n < 27, and the villages are labeled with the first n letters of the alphabet, capitalized. Each data set is completed with n-1 lines that start with village labels in alphabetical order. There is no line for the last village. Each line for a village starts with the village label followed by a number, k, of roads from this village to villages with labels later in the alphabet. If k is greater than 0, the line continues with data for each of the k roads. The data for each road is the village label for the other end of the road followed by the monthly maintenance cost in aacms for the road. Maintenance costs will be positive integers less than 100. All data fields in the row are separated by single blanks. The road network will always allow travel between all the villages. The network will never have more than 75 roads. No village will have more than 15 roads going to other villages (before or after in the alphabet). In the sample input below, the first data set goes with the map above.

The output is one integer per line for each data set: the minimum cost in aacms per month to maintain a road system that connect all the villages. Caution: A brute force solution that examines every possible set of roads will not finish within the one minute time limit.
 
Sample Input
9
A 2 B 12 I 25
B 3 C 10 H 40 I 8
C 2 D 18 G 55
D 1 E 44
E 2 F 60 G 38
F 0
G 1 H 35
H 1 I 35
3
A 2 B 10 C 40
B 1 C 20
0
 
Sample Output
216
30
 
Source
分析:
注意输入,模板题,很水
#include<bits/stdc++.h>
using namespace std;
#define INF 1000000
#define max_v 30
int g[max_v][max_v];//g[i][j] 表示i点到j点的距离
int n,sum;
void init()
{
    for(int i=0; i<n; i++)
        for(int j=0; j<n; j++)
            g[i][j]=INF;
}
void prim()
{
   // int close[n];//记录不在s中的点在s中的最近邻接点
    int lowcost[n];//记录不在s中的点到s的最短距离,即到最近邻接点的权值
    int used[n];//点在s中为1,否则为0
    for(int i=0; i<n; i++)
    {
        //初始化,s中只有一个点(0)
        lowcost[i]=g[0][i];//获取其他点到0点的距离,不相邻的点距离无穷大
      //  close[i]=0;//初始化所有点的最近邻接点都为0点
        used[i]=0;//初始化所有点都没有被访问过
    }
    used[0]=1;
    for(int i=1; i<n; i++)
    {
        //找点
        int j=0;
        for(int k=0; k<n; k++) //找到没有用过的且到s距离最小的点
        {
            if(!used[k]&&lowcost[k]<lowcost[j])
                j=k;
        }
       //  printf("%d %d %d\n",close[j]+1,j+1,lowcost[j]);
        sum+=lowcost[j];
        used[j]=1;//j点加入到s中
        //松弛
        for(int k=0; k<n; k++)
        {
            if(!used[k]&&g[j][k]<lowcost[k])
            {
                lowcost[k]=g[j][k];
             //   close[k]=j;
            }
        }
    }
}
int main()
{
    while(~scanf("%d",&n))
    {
        if(n==0)
            break;
        sum=0;
        init();
        getchar();
        for(int i=0;i<n-1;i++)
        {
            char c;
            scanf("%c",&c);
            int m;
            scanf("%d",&m);
            for(int j=0;j<m;j++)
            {
                getchar();
                char d;
                scanf("%c",&d);
                int x;
                scanf("%d",&x);
                g[c-'A'][d-'A']=x;
                g[d-'A'][c-'A']=x;
            }
            getchar();
        }
        prim();
        printf("%d\n",sum);
    }
    return 0;
}
 

猜你喜欢

转载自www.cnblogs.com/yinbiao/p/9183989.html