hdu 1301 Jungle Roads


The Head Elder of the tropical island of Lagrishan has a problem. A burst of foreign aid money was spent on extra roads between villages some years ago. But the jungle overtakes roads relentlessly, so the large road network is too expensive to maintain. The Council of Elders must choose to stop maintaining some roads. The map above on the left shows all the roads in use now and the cost in aacms per month to maintain them. Of course there needs to be some way to get between all the villages on maintained roads, even if the route is not as short as before. The Chief Elder would like to tell the Council of Elders what would be the smallest amount they could spend in aacms per month to maintain roads that would connect all the villages. The villages are labeled A through I in the maps above. The map on the right shows the roads that could be maintained most cheaply, for 216 aacms per month. Your task is to write a program that will solve such problems. 

The input consists of one to 100 data sets, followed by a final line containing only 0. Each data set starts with a line containing only a number n, which is the number of villages, 1 < n < 27, and the villages are labeled with the first n letters of the alphabet, capitalized. Each data set is completed with n-1 lines that start with village labels in alphabetical order. There is no line for the last village. Each line for a village starts with the village label followed by a number, k, of roads from this village to villages with labels later in the alphabet. If k is greater than 0, the line continues with data for each of the k roads. The data for each road is the village label for the other end of the road followed by the monthly maintenance cost in aacms for the road. Maintenance costs will be positive integers less than 100. All data fields in the row are separated by single blanks. The road network will always allow travel between all the villages. The network will never have more than 75 roads. No village will have more than 15 roads going to other villages (before or after in the alphabet). In the sample input below, the first data set goes with the map above. 

The output is one integer per line for each data set: the minimum cost in aacms per month to maintain a road system that connect all the villages. Caution: A brute force solution that examines every possible set of roads will not finish within the one minute time limit. 

Input

9
A 2 B 12 I 25
B 3 C 10 H 40 I 8
C 2 D 18 G 55
D 1 E 44
E 2 F 60 G 38
F 0
G 1 H 35
H 1 I 35
3
A 2 B 10 C 40
B 1 C 20
0

Output

216
30

Sample Input

9
A 2 B 12 I 25
B 3 C 10 H 40 I 8
C 2 D 18 G 55
D 1 E 44
E 2 F 60 G 38
F 0
G 1 H 35
H 1 I 35
3
A 2 B 10 C 40
B 1 C 20
0

Sample Output

216
30

数字用字符表示了,字符代表城市,然后给出n-1列城市之间的关系,每行第一个是城市,后面跟着一个数字代表后面有几个和最开始的城市是有联系的。
然后就是kruskal的一个模板了。写来练练手(练下并查集和kruskal求最小生成树)

#include<algorithm>
#include<iostream>
#include<cstring>
#include<cstdio>
#include<string>
#include<cmath>
#include<map>
#define debug(a) cout << #a << " " << a << endl
using namespace std;
typedef long long ll;
const int MAXN = 100010;
struct node {
    int x, y, z;
};
node edge[MAXN];
int n, m, pre[MAXN], num;
bool cmp( node a, node b ) {
    if( a.z != b.z ) {
        return a.z < b.z;
    }
}
int find( int x ) {
    int r = x;
    while( r != pre[r] ) {
        r = pre[r];
    }
    int i = x, j;
    while( pre[i] != r ) {
        j = pre[i];
        pre[i] = r;
        i = j;
    }
    return r;
}
void join( int x, int y ) {
    int fx = find(x), fy = find(y);
    if( fx != fy ) {
        pre[fx] = fy;
    }
}
void kruskal() {
    int sum = 0;
    for( int i = 0; i < num; i ++ ) {
        int fx = find( edge[i].x );
        int fy = find( edge[i].y );
        if( fx != fy ) {
            sum += edge[i].z;
            pre[fx] = pre[fy];
        }
    }
    cout << sum << endl;
}
int main() {
    while( cin >> n ) {
        if( !n ) {
            break;
        }
        for( int i = 0; i < MAXN; i ++ ) {
            pre[i] = i;
        }
        n --;
        num = 0;
        while( n -- ) {
            char x, y;
            int t, w;
            cin >> x >> t;
            while( t -- ) {
                cin >> y >> w;
                edge[num].x = ( x - 'A' ), edge[num].y = ( y - 'A' );
                edge[num++].z = w;
            }
        }
        sort( edge, edge + num, cmp );
        kruskal();
    }
    return 0;
}


猜你喜欢

转载自www.cnblogs.com/l609929321/p/9008546.html