POJ 3111 K best 二分

Demy has n jewels. Each of her jewels has some value vi and weight wi.

Since her husband John got broke after recent financial crises, Demy has decided to sell some jewels. She has decided that she would keep k best jewels for herself. She decided to keep such jewels that their specific value is as large as possible. That is, denote the specific value of some set of jewels S = {i1i2, …, ik} as

.

Demy would like to select such k jewels that their specific value is maximal possible. Help her to do so.

Input

The first line of the input file contains n — the number of jewels Demy got, and k— the number of jewels she would like to keep (1 ≤ k ≤ n ≤ 100 000).

The following n lines contain two integer numbers each — vi and wi (0 ≤ vi ≤ 106, 1 ≤ wi ≤ 106, both the sum of all vi and the sum of all wi do not exceed 107).

Output

Output k numbers — the numbers of jewels Demy must keep. If there are several solutions, output any one.

Sample Input
3 2
1 1
1 2
1 3
Sample Output
1 2

正常的01分数规划

跟上一篇文章一样https://mp.csdn.net/postedit/80602317

乱搞一下 

输出即可

#include <cstdio>
#include <cstring>
#include <iostream>
#include <cmath>
#include <algorithm>
using namespace std;
#define dbg(x) cout<<#x<<" = "<< (x)<< endl
const int MAX_N = 1024;
int n,m;
double x;
struct node {
   int w;
   int s;
   bool operator < (const node& other) const{
      return w-x*s>other.w-x*other.s;
   }
}arr[MAX_N];
int check(double p){
    double total_a = 0, total_b = 0;
    x = p;
    sort(arr+1,arr+1+n);
    for(int i = 1;i<=(n-m);++i){
        total_a+=arr[i].w;
        total_b+=arr[i].s;
    }
    return total_a/total_b > p;
}
int main(){
 while(~scanf("%d%d",&n,&m)&&(n||m)){
    for(int i=1;i<=n;++i)
        scanf("%d",&arr[i].w);
    for(int i=1;i<=n;++i)
        scanf("%d",&arr[i].s);
    double l = 0,r=1;
    while(abs(r-l)>1e-4){
        double mid =(l+r)/2;
        if(check(mid)) l=mid;
        else r=mid;
    }
    printf("%.0f\n",l*100);
 }
 return 0;
}
耗时较久 可以用牛顿迭代

猜你喜欢

转载自blog.csdn.net/heucodesong/article/details/80602438