POJ - 1258 【最小生成树】

Agri-Net
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 65906   Accepted: 27280

Description

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course. 
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms. 
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm. 
The distance between any two farms will not exceed 100,000. 

Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

Sample Input

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

Sample Output

28

Source

[Submit]   [Go Back]   [Status]   [Discuss]

Home Page   Go Back  To top

题目链接:点击打开链接

最小生成树模板,和之前的两道的解法相同,这里就是多了一个邻接矩阵·存图。

#include<cstdio>
#include<algorithm>
#include<cstring>
#include<cmath>
#include<iostream>
#define MAXN 10001
using namespace std;
int pre[MAXN],map[MAXN][MAXN];
struct node{
	int to,next,cost;
}edge[MAXN];
void init(int n){
	for(int i=1;i<=n;i++){
		pre[i]=i;
	}
}
int find(int x){
	if(x==pre[x]) return x;
	else{
		pre[x]=find(pre[x]);
		return pre[x];
	}
}
int join(int x,int y){
	int fx=find(x),fy=find(y);
	if(fx!=fy){
		pre[fx]=fy;
		return 1;
	}
	return 0;
}
bool cmp(node a,node b){
	return a.cost<b.cost;
}
int main(){
	int n;
	while(~scanf("%d",&n)){
		init(n);
		int i,j,k;
		for(i=1;i<=n;i++){
			for(j=1;j<=n;j++){
				scanf("%d",&map[i][j]);
			}
		}
		k=0;
		for(i=1;i<=n;i++){
			for(j=1;j<=n;j++){
				//if(i!=j){
				
				edge[k].to=i;
				edge[k].next=j;
				edge[k++].cost=map[i][j];
			}
			//}
		}
		int sum=0;
		sort(edge,edge+k,cmp);
		int cnt=0;
		for(i=0;i<k;i++){
			if(join(edge[i].to,edge[i].next)){
				sum=sum+edge[i].cost;
				cnt++;
			}
			if(cnt==n-1) break;
		}
		printf("%d\n",sum);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/xiang_hehe/article/details/80063119
今日推荐