整数因子分解问题

整数因子分解问题

Time Limit: 1000 ms  Memory Limit: 65536 KiB

Problem Description

大于1的正整数n可以分解为:n=x1*x2*…*xm。例如,当n=12 时,共有8 种不同的分解式: 
12=12; 
12=6*2; 
12=4*3; 
12=3*4; 
12=3*2*2; 
12=2*6; 
12=2*3*2; 
12=2*2*3。
对于给定的正整数n,计算n共有多少种不同的分解式。

Input

输入数据只有一行,有1个正整数n (1≤n≤2000000000)。

Output

将计算出的不同的分解式数输出。

Sample Input

12

Sample Output

8

Hint

#include <iostream>
#include <map>
#include <math.h>

using namespace std;

map<int ,int> a;

int f(int n)
{
    if(n==1)
        return 1;
    if(a[n])
        return a[n];
    int count=1;

    for(int i=2;i<=sqrt(n);i++)
    {
        if(n%i==0)//i是n的因子
        {
            count=count+f(i);
            if(i!=n/i)//搜索另一个不同的因子
            {
                count=count+f(n/i);
            }
        }
    }
    a[n]=count;
    return count;
}

int main()
{
    int n;
    scanf("%d",&n);
    printf("%d",f(n));
    return 0;
}


猜你喜欢

转载自blog.csdn.net/matrix97/article/details/79947984