HDOJ--2899Strange fuction!!!!二分法 (三分)

原文链接

 

 


Problem Description

Now, here is afuction:
  F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100)
Can you find the minimum value when x is between 0 and 100.

 

 

Input

The first line ofthe input contains an integer T(1<=T<=100) which means the number of testcases. Then T lines follow, each line has only one real numbers Y.(0 < Y<1e10)

 

 

Output

Just the minimumvalue (accurate up to 4 decimal places),when x is between 0 and 100.

 

 

Sample Input

2

100

200

 

 

Sample Output

-74.4291

-178.8534

 

 

 

题目大意:给你一个y,输出这个函数在0-100之间最小值

 

思路:二分or三分

 

二分:函数  F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x(0 <= x <=100)没有y*x的时候是单调递增的

y*x可以影响他的导函数的正负,如果求导<0100的时候就是最小,否则,找求导为0的点,最小

 

代码:

#include<stdio.h>
#include<math.h>
double y;
double f(double x)
{
	return 6*pow(x,7.0)+8*pow(x,6.0)+7*pow(x,3.0)+5*pow(x,2.0)-y*x;
}
double daoshu(double x)
{
	return 42*pow(x,6.0)+48*pow(x,5.0)+21*pow(x,2.0)+10*x-y;
}
int main()
{
	int T;
	double l,r;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%lf",&y);
		if(daoshu(100)<=y)
			printf("%.4lf\n",f(100));
		else
		{
			l=0;r=100;
			while(r-l>1e-10)
			{
				double mid=(l+r)/2;
				if(daoshu(mid)<0)
					l=mid;
				else r=mid;
			}
			printf("%.4lf\n",f(r));
		}
	}
	
	return 0;
}


 

 

三分法(前提是凸性)第一次使用,半懵半解

 

代码:

#include<stdio.h>
#include<math.h>
double y;
double f(double x)
{
	return 6*pow(x,7.0)+8*pow(x,6.0)+7*pow(x,3.0)+5*pow(x,2.0)-y*x;
}
int main()
{
	int T;
	double l,r,m,x1,x2;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%lf",&y);
		x1=0;x2=100;
		while(x2-x1>1e-10)
		{
			l=(2*x1+x2)/3;
			r=(x1+2*x2)/3;
			if(f(l)>f(r))	x1=l;
			else			x2=r;
		}
		printf("%.4lf\n",f(r));
	}
	
	return 0;
}




猜你喜欢

转载自blog.csdn.net/y_cnew/article/details/78608423
今日推荐