Can you answer these queries?【线段树+剪枝】

Can you answer these queries?

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)
Total Submission(s): 22229    Accepted Submission(s): 5264


Problem Description
A lot of battleships of evil are arranged in a line before the battle. Our commander decides to use our secret weapon to eliminate the battleships. Each of the battleships can be marked a value of endurance. For every attack of our secret weapon, it could decrease the endurance of a consecutive part of battleships by make their endurance to the square root of it original value of endurance. During the series of attack of our secret weapon, the commander wants to evaluate the effect of the weapon, so he asks you for help.
You are asked to answer the queries that the sum of the endurance of a consecutive part of the battleship line.

Notice that the square root operation should be rounded down to integer.
 

Input
The input contains several test cases, terminated by EOF.
  For each test case, the first line contains a single integer N, denoting there are N battleships of evil in a line. (1 <= N <= 100000)
  The second line contains N integers Ei, indicating the endurance value of each battleship from the beginning of the line to the end. You can assume that the sum of all endurance value is less than 2 63.
  The next line contains an integer M, denoting the number of actions and queries. (1 <= M <= 100000)
  For the following M lines, each line contains three integers T, X and Y. The T=0 denoting the action of the secret weapon, which will decrease the endurance value of the battleships between the X-th and Y-th battleship, inclusive. The T=1 denoting the query of the commander which ask for the sum of the endurance value of the battleship between X-th and Y-th, inclusive.
 

Output
For each test case, print the case number at the first line. Then print one line for each query. And remember follow a blank line after each test case.
 

Sample Input
 
  
10 1 2 3 4 5 6 7 8 9 10 5 0 1 10 1 1 10 1 1 5 0 5 8 1 4 8
 

Sample Output
 
  
Case #1: 19 7 6
 

Source
 

Recommend
lcy
 

思路:

可以分析得到一个int范围内的数最多开6次平方根就可以变成1。这样看来进行有效的点修改的次数并不会很多。当一个数变为1的时候就不用进行更新了。即,当一个区间的值全部为1时,不用进行更新。可以利用这个进行剪枝。

坑点:此题输入的l,r,l可能大于r。

代码:

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<vector>
#include<queue>
#include<math.h>
using namespace std;
#define inf 0x3f3f3f3f
#define MAXN 100005
#define ll unsigned long long
int n,m;
ll sum[MAXN*4];
void build(int v,int L,int R)
{
    if(L==R)
    {
        ll u;
        scanf("%llu",&u);
        sum[v]=u;
        return;
    }
    int mid=(L+R)/2;
    build(v*2,L,mid);
    build(v*2+1,mid+1,R);
    sum[v]=sum[v*2]+sum[v*2+1];
}
void updata(int v,int L,int R,int ql,int qr)
{
    if(sum[v]==R-L+1) return ;
    if(L==R)
    {
        sum[v]=(ll)sqrt(sum[v]);
        return;
    }
    int mid=(L+R)/2;
    if(ql<=mid) updata(v*2,L,mid,ql,qr);
    if(qr>mid) updata(v*2+1,mid+1,R,ql,qr);
    sum[v]=sum[v*2]+sum[v*2+1];
}
ll query(int v,int L,int R,int ql,int qr)
{
    if(ql<=L && R<=qr)
    {
        return sum[v];
    }
    ll ret=0;
    int mid=(L+R)/2;
    if(ql<=mid) ret+=query(v*2,L,mid,ql,qr);
    if(qr>mid) ret+=query(v*2+1,mid+1,R,ql,qr);
    return ret;
}
int main()
{
    int cas=1;
    while(~scanf("%d",&n))
    {
        printf("Case #%d:\n",cas++);
        build(1,1,n);
        scanf("%d",&m);
        for(int i=0;i<m;i++)
        {
            int op,l,r;
            scanf("%d%d%d",&op,&l,&r);
            if(l>r) swap(l,r);
            if(op==0) updata(1,1,n,l,r);
            else printf("%llu\n",query(1,1,n,l,r));
        }
        printf("\n");
    }
	return 0;
}

猜你喜欢

转载自blog.csdn.net/u013852115/article/details/80528868