HDU4027 Can you answer these queries?【线段树】

Can you answer these queries?

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)
Total Submission(s): 23332    Accepted Submission(s): 5550


 

Problem Description

A lot of battleships of evil are arranged in a line before the battle. Our commander decides to use our secret weapon to eliminate the battleships. Each of the battleships can be marked a value of endurance. For every attack of our secret weapon, it could decrease the endurance of a consecutive part of battleships by make their endurance to the square root of it original value of endurance. During the series of attack of our secret weapon, the commander wants to evaluate the effect of the weapon, so he asks you for help.
You are asked to answer the queries that the sum of the endurance of a consecutive part of the battleship line.

Notice that the square root operation should be rounded down to integer.

 

Input

The input contains several test cases, terminated by EOF.
  For each test case, the first line contains a single integer N, denoting there are N battleships of evil in a line. (1 <= N <= 100000)
  The second line contains N integers Ei, indicating the endurance value of each battleship from the beginning of the line to the end. You can assume that the sum of all endurance value is less than 263.
  The next line contains an integer M, denoting the number of actions and queries. (1 <= M <= 100000)
  For the following M lines, each line contains three integers T, X and Y. The T=0 denoting the action of the secret weapon, which will decrease the endurance value of the battleships between the X-th and Y-th battleship, inclusive. The T=1 denoting the query of the commander which ask for the sum of the endurance value of the battleship between X-th and Y-th, inclusive.

 

Output

For each test case, print the case number at the first line. Then print one line for each query. And remember follow a blank line after each test case.

 

Sample Input

 

10 1 2 3 4 5 6 7 8 9 10 5 0 1 10 1 1 10 1 1 5 0 5 8 1 4 8

 

Sample Output

 

Case #1: 19 7 6

 

Source

The 36th ACM/ICPC Asia Regional Shanghai Site —— Online Contest

问题链接HDU4027 Can you answer these queries?

问题简述:(略)

问题分析

  这个问题基本上算是一个线段树的模板题。

  给定N个数,M个命令。命令格式是:T X Y。如果T=0则将区间[x,y]的各个数开平方,如果T=1则查询区间的[x,y]的和。

程序说明

  这个程序的写法要简单许多,计算速度也要快许多。

题记:(略)

参考链接:(略)

AC的C++语言程序如下:

/* HDU4027 Can you answer these queries? */

#include <iostream>
#include <stdio.h>
#include <math.h>

using namespace std;

typedef long long LL;

const int N = 1e5;
LL sum[(N << 2) + 1];

void pushup(int root)
{
    sum[root] = sum[root << 1] + sum[(root << 1) + 1];
}

void build(int root, int l, int r)
{
    if(l == r)
        scanf("%lld", &sum[root]);
    else {
        int mid = (l + r) >> 1;
        build(root << 1, l, mid);
        build((root << 1) + 1, mid + 1, r);
        pushup(root);
    }
}

void update(int root, int l, int r, int ql, int qr)
{
    if(l == r)
        sum[root] = sqrt(sum[root]);
    else if(ql <= l && qr >= r && sum[root] == r - l + 1)
        ;
    else {
        int mid = (l + r) >> 1;
        if(ql <= mid)
            update(root << 1, l, mid, ql, qr);
        if(qr > mid)
            update((root << 1) + 1, mid + 1, r, ql, qr);
        pushup(root);
    }
}

LL query(int root, int l, int r, int ql, int qr)
{
    if(ql <= l && qr >= r)
        return sum[root];
    else {
        int mid = (l + r) / 2;
        LL sum = 0;
        if(ql <= mid)
            sum += query(root << 1, l, mid, ql, qr);
        if(qr > mid)
            sum += query((root << 1) + 1, mid + 1, r, ql, qr);
        return sum;
    }
}

int main()
{
    int n, m, caseno = 0;
    while(scanf("%d", &n) == 1) {
        build(1, 1, n);

        scanf("%d", &m);
        printf("Case #%d:\n", ++caseno);
        while(m--) {
            int t, x, y;
            scanf("%d%d%d", &t, &x, &y);
            int x2 = min(x, y), y2 = max(x, y);
            if(t)
                printf("%lld\n", query(1, 1, n, x2, y2));
            else
                update(1, 1, n, x2, y2);
        }
        printf("\n");
    }

    return 0;
}

猜你喜欢

转载自blog.csdn.net/tigerisland45/article/details/81322976